Closed Bug 303675 Opened 15 years ago Closed 15 years ago

downloads fail silently if the default download path is invalid, e.g. leads to a removed drive

Categories

(SeaMonkey :: Download & File Handling, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

Attachments

(1 file, 2 obsolete files)

SM version of bug 270557 - summary says it all :-)
Attached patch Simple patch v0.1 (obsolete) — Splinter Review
This patch
* Adds dir.exists() checks to the relevant places in nsHelperAppDlg.js and
contentAreaUtils.js
Assignee: download-manager → bugzilla
Status: NEW → ASSIGNED
Attachment #191801 - Flags: review?(cbiesinger)
Comment on attachment 191801 [details] [diff] [review]
Simple patch v0.1

+	 if (dir && dir.exists() && autoDownload) {

autoDownload is faster to check, so I'd check that before .exists(). it's also
more likely to be false.

(both files)
Attachment #191801 - Flags: review?(cbiesinger) → review+
Attached patch Revised patch v0.2 (obsolete) — Splinter Review
Changes since v0.1:
* Addressed reviewer's comments wrt order of checks

Carrying forward r= and requesting sr=
Attachment #191801 - Attachment is obsolete: true
Attachment #191809 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #191809 - Flags: review+
Comment on attachment 191809 [details] [diff] [review]
Revised patch v0.2

I think that it would be even clearer still if autoDownload was tested first.
Attachment #191809 - Flags: superreview?(neil.parkwaycc.co.uk) → superreview+
Changes since v0.2
* Shuffled order of checks as per Neil's comments

Carrying forward r= and sr=

Requesting a= for very low risk patch.
Attachment #191809 - Attachment is obsolete: true
Attachment #191871 - Flags: superreview+
Attachment #191871 - Flags: review+
Attachment #191871 - Flags: approval1.8b4?
Attachment #191871 - Flags: approval1.8b4? → approval1.8b4+
Comment on attachment 191871 [details] [diff] [review]
Tweaked patch v0.3 (Checked in)

Checking in
embedding/components/ui/helperAppDlg/nsHelperAppDlg.js;
new revision: 1.69; previous revision: 1.68
xpfe/communicator/resources/content/contentAreaUtils.js;
new revision: 1.134; previous revision: 1.133
done
Attachment #191871 - Attachment description: Tweaked patch v0.3 → Tweaked patch v0.3 (Checked in)
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
*** Bug 202735 has been marked as a duplicate of this bug. ***
*** Bug 257052 has been marked as a duplicate of this bug. ***
There is an older Bug 142664(browser.download.dir case) in addition to DUP
closed Bug 202735 and Bug 257052.
Ian Neal, does your patch fix Bug 142664 too?
How about another Bug 240644 case(mail.compose.attach.dir case)? 
Bug 142664 is not one I can reproduce, but it is probably best you comment in
the bugs mentioned than in here.
Duplicate of this bug: 318160
You need to log in before you can comment on or make changes to this bug.