2 customize panels save diff. settings to 2 browser windows

VERIFIED WORKSFORME

Status

SeaMonkey
Sidebar
P1
normal
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: kas, Assigned: Steve Lamm)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
(This bug imported from BugSplat, Netscape's internal bugsystem.  It
was known there as bug #387276
http://scopus.netscape.com/bugsplat/show_bug.cgi?id=387276
Imported into Bugzilla on 03/03/00 16:36)

If you open 2 browser windows and click on the customize sidebar link on both, 
you will see that a second customize window will open and each will save changes 
only to its own respective browser window. This will cause confusion because you 
will have different settings with each browser window.For example you can have no 
panels at all in one browser and in the other you can have a few ones displayed. 
And if you open more browser windows they will inherit what the settings were on 
the active browser using ( CTRL  N) or the one browser that you use its File> New 
Browser menu.
Every new browser windows should reference the same customize panel and they 
should all dynamically update with any changes saved through the one customize 
panel.
To reproduce:
1. Launch the seamonkey browser (build #2000022708)
2. Open 2 browser windows side by side
3. Click on the customize sidebar link of each browser to get 2 customize windows 
open
4. Make different changes in each one and click save
RESULT:
Each browser will update the changes made in its own customize window

Comment 1

18 years ago
reassign to slamm
Assignee: ajayebi → slamm
Status: NEW → UNCONFIRMED

Comment 2

18 years ago
why hasn't this been marked as new yet?!
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
ryanm@cfl.rr.com:I'm assuming by marking this bug as NEW you meant to say "I've reproduced this bug with current builds[build 
date]. It is indeed valid. I've also looked at the different fields/settings and determined they are pretty much correct too. marking 
NEW"

Is that the case? because that's what it means to confirm a bug and mark it new and why this bug had not been marked as such.

Comment 4

18 years ago
I should be more careful. I think I had more than one bug open and I made the 
changes to the wrong one. There was a case where the it seemed as if the 
previous person forgot to mark the bug as new (it was blantanly obvious) I 
thought I was being careful, I'll be more careful from now on. Sorry for the 
mistake.

Comment 5

18 years ago
I cannot seem to reproduce this. Only one Customize window opens now. Marking 
WFM.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

17 years ago
v
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

17 years ago
This is an old bug that needs to be closed. Who closes the bug?
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.