Get 304 Not Modified error loading script




Networking: HTTP
18 years ago
4 years ago


(Reporter: stuffduff, Assigned: Darin Fisher)


Windows NT

Firefox Tracking Flags

(Not tracked)


(Whiteboard: [NEED INFO][nsbeta3-], URL)



18 years ago
if you are not the person to contact please point me in the right direction.

using javascript to write content to child frame
works in NN4.7 and MSIE 5.01
but not in Mozilla


18 years ago
Component: Core → DOM Level 0
Product: Rhino → Browser

Comment 1

18 years ago
What's going on is that when Mozilla attempts to load, it gets back "<HTML><HEAD><TITLE>304 Not
modified</TITLE></HEAD>..." prepended to the contents of the .js file. I don't
know why that's happening--could it be an error in our networking code? Neither
4.x or IE have the problem.
Assignee: norris → gagan
Component: DOM Level 0 → Networking
QA Contact: cbegle → tever
Summary: index.html uses javascript to write menu to child frame → Get 304 Not Modified error loading script

Comment 2

18 years ago
Hmmm... interesting, a trace on 4.7 shows two requests for the same .js file but
only one response. Since 304 means we did a If-Modified-Since, we are probably
not patching the response back correctly. cc'ing cache guys.


18 years ago
Target Milestone: M15

Comment 3

18 years ago
cc'ing with more force... :) ->gordon
Assignee: gagan → gordon

Comment 4

18 years ago
The problem may be related to the fact that mozilla doesn't update the URL it's 
viewing when it recieves a 304. This is Bad. If you reload once the page is 
loaded, then the correct URL is shown. To view for yourself, follow any 
applications homepage/changelog/download type link at - 
they all use freakin 304s...


18 years ago
Target Milestone: M15 → M17

Comment 5

18 years ago
Moving post beta bugs to M18 which is now the post-beta milestone.
Target Milestone: M17 → M18


18 years ago
Keywords: nsbeta3

Comment 6

18 years ago
need more info on if this is still happening. 
Keywords: qawanted


18 years ago
Whiteboard: [NEED INFO]

Comment 7

18 years ago
no info as yet. and too late.
Whiteboard: [NEED INFO] → [NEED INFO][nsbeta3-]

Comment 8

18 years ago
worksforme under Mac OS 9.0.4, so must be WinNT bug.

mozilla build 2000092804-M18.

Comment 9

18 years ago
Clarification; amplification.

When I said "worksforme" I should have said, "I don't get a 'Get 304 Not
Modified error loading script."  I should have checked under NC 4.75 before
posting to bugzilla.  My bad.

When I load this page on the Mac under Mac OS 9.0.4 and build 2000092804-M18,
all I get is a blue field on the lefthand side of the page.  There are two
slightly different shades of blue in the box, as though a rectangular box is
overpainting where the javascript menu items are supposed to be.  The javascript
does *not* appear to be processed.  In my JavaScript console, the following
message appears:

"Error:  menu.document.xmenu has no properties

Source file:

Line:  180                                Column:  0"

Now under NC 4.75 on the Mac, I have to reload the page to get it to work.  The
first time I load the page, I get a grey box with the javascript menu items
visible.  Two pictures on the right were not shown.  When I reload, the
javascript menu items appear in a blue box which does *not* have two different
shades of blue as I described above.  At *no* time on the Mac did I see the "Get
304 Not Modified error loading script" message, which led me to believe it
worked on the Mac, thus my earlier post.

Hope this helps, sorry for any inconvienence.

Comment 10

18 years ago
Finally tried Netscape 6
No Joy.


17 years ago
Target Milestone: M18 → mozilla0.9

Comment 11

17 years ago
Still not fixed with the new cache.  We'll need to investigate for 0.9.1.
Target Milestone: mozilla0.9 → mozilla0.9.1

Comment 12

17 years ago
This is more likely to be a problem with HTTP than the cache. Darin, what do you 
Assignee: gordon → darin
Component: Networking → Networking: HTTP

Comment 13

17 years ago
neeti: do you think you could help investigate this bug?  are we still seeing
this error in recent builds?  thanks!
Keywords: helpwanted

Comment 14

17 years ago
this appears to be fixed now.
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
I can't connect to that url - eventually the connection just times out.

Comment 16

17 years ago
the server just appears to be down.

Comment 17

16 years ago
Verified WFM.
QA Contact: tever → junruh
Keywords: helpwanted, qawanted
You need to log in before you can comment on or make changes to this bug.