After moving DeerPark.app, many commands (such as Quit) stop working

RESOLVED DUPLICATE of bug 396485

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 396485
13 years ago
8 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050806
Firefox/1.0+

Steps to reproduce:
1. Launch Firefox.
2. Open the JavaScript console (optional).
3. Drag DeerPark.app file from Desktop to a subfolder of Desktop.
4. Focus Firefox again and press Cmd+Q.

Result:

* uncaught exception: [Exception... "Component returned failure code: 0x80570019
(NS_ERROR_XPC_CANT_CREATE_WN) [nsIJSCID.getService]" nsresult: "0x80570019
(NS_ERROR_XPC_CANT_CREATE_WN)" location: "JS frame ::
chrome://global/content/globalOverlay.js :: goQuitApplication :: line 51" data: no]

* A blank error at jar:[old location of
.app]/Contents/MacOS/chrome/toolkit.jar!/content/global/platformHTMLBindings.xml
Line 1

* Firefox does not quit.  I have to Force Quit.

Expected: Quit when I press Cmd+Q.

I ran into this because I keep the latest nightly on my desktop and move old
nightlies into a folder called "old firefox trunk".  This happened to me about 6
times before I figured out how to reproduce it (move the .app file of a running
instance of Firefox).  I don't know whether this is a bug in Firefox (are Mac OS
X apps expected to continue working if moved while running?) or a bug in Mac OS
X (should Finder warn/disallow me from moving running applications?).
Bug 396485 has a bit more info.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 396485
You need to log in before you can comment on or make changes to this bug.