crash or attempted crash anytime the download manager is either called up or something is set to download while the download manager is up on the screen

RESOLVED DUPLICATE of bug 280442

Status

()

Toolkit
Downloads API
--
critical
RESOLVED DUPLICATE of bug 280442
13 years ago
10 years ago

People

(Reporter: Jamison, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

i've had this problem in all versions of firefox that i've used, going back
quite a few builds from the newest release. the firefox window freezes whenever
the download manager is called up, whenever anything is selected to be
downloaded while the manager is up, and any time more than one thing is set to
download at the same time. often the result can be a major crash of firefox,
wiping out everything that i've been working on. basically, the download manager
needs some major work, as the current version has more bugs than a rainforest.

Reproducible: Always

Steps to Reproduce:
1. set a file to download
2. open the download manager

1. open the download manager
2. set a file to download

Actual Results:  
firefox froze and attempted to crash

Expected Results:  
downloaded the file without crashing the program

Comment 1

13 years ago
Sounds like it's an issue with an extension. Do you see this in safe mode?
http://kb.mozillazine.org/Safe_mode
Please use the instructions here: http://kb.mozillazine.org/Talkback to install
the Talkback client, recrash, then copy the incident ID from
/components/talkback.exe and post it to this bug.

Comment 3

13 years ago
I have the same behavior on the same platform (Windows XP) any firefox download,
which is a pity because it prevents me from moving from Mozilla to Firefox (any
download works fine with my Mozilla 8.1 alpha). I tried a clean install, even
without mozilla previously installed, with no success.

Comment 4

13 years ago
I can confirm that the same is occurring either in safe mode (no extensions at
all) or using talkback enabled. Talkback sees nothing. It looks like that crash
(a freeze, actually) is too violent. This occur on any download. Clicking on a
link that should prompt for download freeze until you kill the process.
Right-clicking on "save as..." pops up the download file dialog, but freezes
endlessly once you selected OK for a download file name, until you kill the
process. Before, during of after killing the process, an enabled talkback sees
nothing.

Comment 5

13 years ago
Same with 1.5 beta 1

Comment 6

13 years ago
...but works with Seamonkey 1.0a ! So I'll stay on the seamonkey branch...
Here the download manager gui is too slow to appear on the screen, before the
download is finished Firefox hangs.

Comment 8

12 years ago
Confirming Win 98SE Firefox 1.5 Beta 1

Same symptoms, no Talkback.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

12 years ago
Yeah. I've been having similar problems. Whenver i try to right click and save an image.. firefox crashes. It's unfortunate because I want to use Firefox but since I can't save stuff from sites I've visited I can't use firefox ........ It only does this for image files and not for video.

Comment 10

12 years ago
For those of you who are seeing this, could you please make sure you have talkback installed so when it does crash you can get a talkback ID?

Also, what are you guys' user-agents? You need to post what version of Firefox you're using when you make a comment that says you see the bug. (UA is in Help > About.)

Comment 11

12 years ago
I may have found the solution to this problem. If there are many files in the default download directory or it's subdirectories, then the download manager spins the cpu processing the download history information. Change the download directory to an empty directory and clean up the download history.

Comment 12

12 years ago
I had the same problem tonight, I tried safe mode and the same crash would happen, reinstalled a few times (both removing and leaving the old install) I installed the quality feedback agent, but had no luck submitting the bug, claimed it couldn't contact the server, but that's another bug for another day.

I also removed all mozilla.org/mozilla related registry entries from the local_user branch of the windows registry.

In the end I made a new user in windows XP and firefox worked fine.

Something I didn't try, is to remove the profile folder/monkey around with the profile settings in the documents and settings folder, you might want to try that.

Comment 13

12 years ago
I also have this problem when finishing a download. But I only have it with Firefox 1.0.7. In the previous versions there weren't any errors.

Maybe it is my graphics card?
Nvidia GeForce 6800; Forceware 81.82.

Comment 14

12 years ago
I also had this problem
deleting the file "downloads.rdf" in my profile fixed it
Incidentially, the contents of the file was 200KB of zeroes
UA: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

It would be nice if that help/about box let you copy text from it (:

Comment 15

12 years ago
(In reply to comment #14)
> I also had this problem
> deleting the file "downloads.rdf" in my profile fixed it
> Incidentially, the contents of the file was 200KB of zeroes
> UA: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111
> Firefox/1.5
> 
> It would be nice if that help/about box let you copy text from it (:
> 
Oh - an additional note: localstore.rdf was all zeroes as well - not sure if that's related.
deleting that fixed it as well (firefox wasn't remembering window positioning)

Comment 16

12 years ago
A temporary solution in Windows XP is to create a new windows user account (Control Panel) and switch to that.  Then try downloading a file in firefox.  For me, the problem went away.

But who's going to switch users everytime they want to download a file?

Using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8) Gecko/20051111 Firefox/1.5
Windows XP SP2
Athlon, Asus A7V chipset.

Comment 17

12 years ago
Mabey not completely related, but i keep getting downloads that die partway through. Its really annoying. The download just stops for no reason. I usually end up using IE to download because that doesnt give me problems.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Comment 18

12 years ago
If I download jpgs, or exe's etc using IE they load perfectly,but in past 3 days if I  try an download anything using Firefox it crashes and logs me out of the internet ??? Using latest Firefox 1.5

Comment 19

12 years ago
Duplicate of bug 280442.
Please feel free to post a talkback id (right right on a talback in the Mozilla Quality Feedback Agent (search for talback.exe) and "Copy"). Then paste it here.
Try to delete the file "downloads.rdf" (be sure to make a backup of it to help fixing this bug).
If it doesn't work, this isn't a duplicate.

*** This bug has been marked as a duplicate of 280442 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.