If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Download only go to desktop despite setting download options

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
--
minor
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Norm H., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

When downloading the download dialog box appears and only allows you to save to
the desktop ("save to disk")is what is shown. When i go into the download
options and tell (set) it to "ask me where to save every file"... it does not
work and only defaults to the original option "save to disk" (desktop); it does
not allow me to save to a folder.

Reproducible: Always

Steps to Reproduce:
1.Go into the tools > options > download, and set download option to "Ask where".
2.Go to the internet and download a file..download box only allows "save to disk".
3.Downloaded file placed on desktop, never ask my choice.

Actual Results:  
Same effect... each time. Never allows me to choose the destination for my
downloads, only to desktop.

Expected Results:  
Dialog box should have asked me to choose where on my hard drive or floppy drive
i wanted to store the file. 

Similar to report # 280254
Not really all that similar to 280254..  I've seen this myself, and had to
manually go into about:config and synchronize the various prefs.

We seem to have 3 different prefs that hold the download location:

browser.download.dir
browser.download.defaultFolder
browser.download.downloadDir

.dir seems to be the one that should be used, but defaultFolder is being used in
some cases -- even though the code seems to be commented out that references
defaultFolder!  Also, some profile migrators seem to set defaultFolder (but not
.dir).  I have no idea where downloadDir comes from...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Download only go to desktop despite setting download options--similar to # 280254 → Download only go to desktop despite setting download options
I've experienced this also on Deer Park Alpha, the problem seems to stem from
multiple browser.download prefs.

Though browser.download.dir and browser.download.downloadDir were both set to
the correct dir, browser.download.defaultFolder was not, and this seems to be
the one that was actually being used for the download target, while one of the
other two was being displayed in the Downloads window and in Options.

Very confusing.
Can either of you reproduce this on current trunk?  There was a bug fixed on not
honouring the ask every time pref, should be fixed now.

Comment 4

12 years ago
In my case download manager downloads into the /Local Settings/Temp direcory in
Documents and Srttings (Windows 2000). 
This was despite the explicit option to ask me where to save download files.
As an example take the dowload at the bottom of following url :
http://www.phlimburg.be/Vacatures/vacature_detail.asp?sleutel=78

Each time I download, a new download file goes into that /Temp directory, but in
the download manager window which appears after downloads, only one download is
shown.

This download problem does not happen for every download, but every time for
that download. In this case it concerns download of a doc file. 

Comment 5

12 years ago
Something very similar happens in Ubuntu Linux 4.10.

I propose that the OS field on this bug report be changed to "All"

In Linux, the download dialog box opens the Gnome file browser, which allows one to navigate alright, but only has an Open button.  When this is clicked, the download folder is not changed to the one that was chosen.
That doesn't seem to be this bug, this bug was about always saving to the auto-download folder instead of prompting.  If you're getting a prompt you're not seeing this bug.

Please file a new bug on distinct issues.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Comment 7

12 years ago
Starting with the original description, and reading through several more,
it looks like you're wrong, Mike.  From the first, they report that they get a dialog, but nothing they do in the dialog results in the files going to a different directory.  Before your comment, I see no mention of the word "prompting".  Are you thinking of a different bug report?

I read through it again.  It really looks like exactly the same bug that I see,
except in Windows rather than in Linux.

But, if you think that makes it different, I'll open a separate bug report.

Are you sure this is fixed?  I have a Windows system...I'll try it there.
There are two dialogs in question here.. one is the "What do you want to do with this" dialog, and the other is the dialog that lets you pick a path.  When the pref is set "Ask where to save", if the bug occurs, the first dialog does show up (what do you want to do with this), but the second (where should I save) does not, even though it should.

It should be easy to test if this bug is still around; set the prefs I mentioned in comment #1 to different dirs, in particular browser.download.defaultFolder, and then see what happens when you click on some downloads.

Comment 9

12 years ago
OK, the bug I'm referring to is 
     300856 Cannot set default download directory to home
Which is very similar.  I withdraw my previous proposal.

I confused it with this (earlier) bug in the Windows version 1.0.7, (which seems now to have been fixed,) because on the face of it they behave the same way.  The bug here is a bad U.I.: Two buttons take you to directory-browsing dialogs, and an item hidden three layers deep at the bottom of a menu displayed the directoy-selecting dialog -- which finally works, but leaves you wondering why you didn't get a prize for finding it.

The Linux bug is that if you select the user's HOME directory,  and click Open,
it doesn't really choose it--which makes the dialog act, for this one directory, like a directory-browsing dialog.
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.