Status bar shows wrong URL because of HREF modification

RESOLVED DUPLICATE of bug 229050

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 229050
13 years ago
13 years ago

People

(Reporter: Dan Mellem, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050308
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050308

The status bar has shown faked information using onMouseOver (bug 40838), but it
can also be done with other trickery like onMouseDown and self-modifying HTML
(DOM/DHTML). One example is to use JavaScript to modify the HREF link the
instant it's clicked on. If there's any events, the status bar should reflect
this somehow or remain blank.

This is seen in Mozilla (Seamonkey) and Firefox.

Reproducible: Always

Steps to Reproduce:
1. Open testcase.
2. Hover over link. Confirm it goes to MozillaZine.
3. Click. You end up at Mozilla.org
Actual Results:  
Status bar shows the link goes to www.mozillazine.org.

Expected Results:  
When hovering over the link, it should either display the correct destination
(if possible), or other information. Perhaps it could say:

Events: onMouseOver, onClick, onMouseDown HREF=www.mozillazine.com

Though this may be too technical for most.
(Reporter)

Comment 1

13 years ago
Created attachment 191868 [details]
Testcase: Changes HREF via onMouseDown
(Reporter)

Updated

13 years ago
Keywords: testcase
Keywords: testcase
(Reporter)

Updated

13 years ago
Keywords: testcase

Comment 2

13 years ago
See also bug 229055 and bug 229050.

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 229050 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

13 years ago
Confirmed on a Mac, too. OS->All, HW->All

Bug 229055 and bug 229050 should be updated then to support all events. Both of
those are for onClick, while this is for onMouseDown and other events.
OS: Windows XP → All
Hardware: PC → All
You need to log in before you can comment on or make changes to this bug.