Shift-Click selects from last click, not first

VERIFIED WORKSFORME

Status

()

Core
XUL
P3
normal
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: Richard Zach, Assigned: David Hyatt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Multiple selection using shift-click to select a range of items in the MailNews
thread pane or the address book, should count from the first selection, not the
last, just like in multiple select fields.

To reproduce:
1. Open Mail folder
2. Select a message (1)
3. Shift-click message (2) below
4. Shift-click message (3) below that  

Actual result: Messages 2 and 3 are selected
Expected result: messages 1, 2, and 3 should be selected.

Linux build 2000.03.03.12
(Assignee)

Comment 1

18 years ago
Oh yeah, so it does.  Cool.
Status: NEW → ASSIGNED
Target Milestone: M15
(Assignee)

Updated

18 years ago
Target Milestone: M15 → M16

Comment 2

18 years ago
Mass-moving all M16 non-feature bugs to M17, which we still consider to be 
part of beta2
Target Milestone: M16 → M17

Comment 3

18 years ago
moving to m18, would take easy fix by 5/16
Target Milestone: M17 → M18

Comment 4

18 years ago
*** Bug 35042 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
mass-moving all bugs to m21 that are not dofood+, or nsbeta2+
Target Milestone: M18 → M21

Comment 6

18 years ago
42109 seems to depend on this one.  The result of 42109, 100% crash, is serious 
for Mac builds, and I would like to ask if this one be given higher priority.

Comment 7

18 years ago
I can't reproduce the crash mentioned in bug 42109, and I doubt this bug is 
directly related. However, since bryner was just working with a similar tree 
selection bug, perhaps he'd like to have a look at wiring up the correct 
selection behaviour for this situation. bryner?

Comment 8

18 years ago
resolving as wfm using today's M18 verification build.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

18 years ago
Verified on 2000.07.30.05 Linux build.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.