Weekly recurrence doesn't work properly

RESOLVED FIXED

Status

Calendar
Sunbird Only
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: Robin Edrenius, Assigned: Mostafa Hosseini)

Tracking

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050806 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050807 Mozilla Sunbird/0.2+

The weekly recurrence only repeats the event on the weekday the first event was
created (i.e if the startday on the first event is on a sunday, it will only
repeat on sundays, even if you select more weekdays)

Reproducible: Always

Steps to Reproduce:
1. Create a event
2. Select weekly recurrence
3. Select multiple weekdays

Actual Results:  
The event is only repeated on the weekday of were the original event was created

Expected Results:  
The event should be repeated on the weekdays that is specified in the recurrence
options for that event.
I think the problem is the same as described in bug 304515 comment 3 and 4.
Setting dependency for now, might turn out to be a duplicate.
Depends on: 304515
When editing the event, are the checkboxes still checked?
And which provider are you using? If it's a local calendar (storage), can you
try a remote calendar (ics, you can use a file:// patch to make it not-so remote)

Comment 3

12 years ago
I'm having the same problem. I am using Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.7.10) Gecko/20050723, the August 22nd build. When I create a recurring
weekly event on a local calander, after I push Okay to create the event, it
recurrs for the first event weekly, but not the other boxes I selected. Editting
the event shows that the boxes are no longer selected.

Using the same build on a (file://) remote calender, the weekly recurring event
function does work as advertised. 
Created attachment 193724 [details] [diff] [review]
simple patch

no need to comment on the patch...
Attachment #193724 - Flags: first-review?(dmose)

Comment 5

12 years ago
Comment on attachment 193724 [details] [diff] [review]
simple patch

r=dmose
Attachment #193724 - Flags: first-review?(dmose) → first-review+
patch checked in. The storage calendar should work properly now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 7

12 years ago
This patch seems to create some very bad problems for me.  With clean profile, I
created a weekly, recurring event.  This results in several copies of:

Error: row[rtypes[i]].split is not a function
Source File:
file:///home/joey/mozhack/mozilla/sunobj2/dist/bin/components/calStorageCalendar.js
Line: 1276

Recuring events created prior to the implementation of this patch are still
dealt with ok.  Only events created/edited after this patch went in cause this
problem.

Re-opening bug.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 8

12 years ago
I should also say that the terminal outputs:
XXXX Expected to find recurrence, but got no items!

Comment 9

12 years ago
Created attachment 193775 [details] [diff] [review]
handle single integer case

Since we're dealing with integers, .split fails if there is only one.  This
patch handles that case.
Attachment #193775 - Flags: first-review?(dmose)

Comment 10

12 years ago
Created attachment 193778 [details] [diff] [review]
better patch

toString() makes things much simpler :-)

r=dmose from IRC
Attachment #193775 - Attachment is obsolete: true
Attachment #193778 - Flags: first-review+

Updated

12 years ago
Attachment #193775 - Flags: first-review?(dmose)

Comment 11

12 years ago
Patch checked in.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.