If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Nulling the home page location causes the first window to be unmaximisable (Maximize button disabled)

RESOLVED FIXED in mozilla1.8final

Status

()

Toolkit
Startup and Profile System
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: gkn, Assigned: mconnor)

Tracking

({fixed1.8, regression})

Trunk
mozilla1.8final
x86
Windows XP
fixed1.8, regression
Points:
---
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
This one's weird.

If browser.startup.homepage is void, the first browser window opened each time
Firefox is started is unmaximisable. The Maximize button and Control menu
command are disabled; Windows will not Tile, Cascade or Size the window. The
resize grippy in the statusbar does still resize the window. Subsequently opened
windows are maximisable.

To reproduce:
1. Set browser.startup.homepage to "" (blank), e.g. by using the Options dialogue
2. Restart Firefox
(Maximize button is disabled.)
3. Right-click Firefox's titlebar
(Maximize and Size are disabled.)
4. Minimise any other open windows and right-click the taskbar
(Tile and Cascade Windows are disabled.)
5. Open a new Firefox window
(The new window maximises and resizes as normal)

Workaround: set browser.startup.homepage to "about:blank"

Comment 1

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050805
Firefox/1.0+ ID:2005080512

Confirmed, and adding that it puts firefox into full-screen mode for me.
This is a regression. It worked in the 2005-01-17 build, but fails in the
2005-01-18 build.
I think it is a regression from fixing bug 276588.
Blocks: 276588
Keywords: regression
(Reporter)

Comment 3

12 years ago
Requesting blocking1.8b4 because I suspect a fair number of users will clear (or
have previously cleared) the homepage location field, get the blank page they
expected and later become confused as to why Firefox won't maximise.
Flags: blocking1.8b4?

Updated

12 years ago
Assignee: nobody → mconnor
Flags: blocking1.8b4? → blocking1.8b4+
(Assignee)

Comment 4

12 years ago
Created attachment 193074 [details] [diff] [review]
reset home page pref to default on startup if there's no value

Discussed with beltzner, we agreed this is the right course to take.  If
someone wants to open a blank homepage, they can click the button.
Attachment #193074 - Flags: review?(benjamin)
(Assignee)

Updated

12 years ago
Whiteboard: [has patch][needs review bsmedberg]

Updated

12 years ago
Attachment #193074 - Flags: review?(benjamin) → review+
Just one question: isn't this a bug in the toolkit command-line handling, perhaps?
(Assignee)

Comment 6

12 years ago
there might be an additional issue, but this patch is still necessary.
(Assignee)

Updated

12 years ago
Whiteboard: [has patch][needs review bsmedberg] → [has patch][needs approval]
(Assignee)

Updated

12 years ago
Attachment #193074 - Flags: approval1.8b4?

Updated

12 years ago
Attachment #193074 - Flags: approval1.8b4? → approval1.8b4+
(Assignee)

Updated

12 years ago
Whiteboard: [has patch][needs approval] → [has patch][needs checkin]
(Assignee)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Whiteboard: [has patch][needs checkin]
Target Milestone: --- → Firefox1.5
*** Bug 279145 has been marked as a duplicate of this bug. ***
This should have been a duplicate of bug 279145 which was opened back in
Jan/2005, but since this report has some discussion and action taken, I'll close
the other one as a duplicate.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.