The default bug view has changed. See this FAQ.

Empty file and wrong file name when the file name contains certain characters

RESOLVED DUPLICATE of bug 66041

Status

()

Core
HTML: Form Submission
--
critical
RESOLVED DUPLICATE of bug 66041
12 years ago
11 years ago

People

(Reporter: Ng Ming Hong, Unassigned)

Tracking

({dataloss})

Trunk
x86
Windows XP
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

This bug sounds similar to bug 273225. But I'm not certain, so I'm filing a new
one here. This bug only occur in Windows.

The unsupported character is replaced with a underscore (_), and the file size
becomes zero.

In my case, I'm using a Chinese (simpified) version of Windows and the file name
is also in Chinese (simpified). So it seems to be rather ridicious that Firefox
can't resolved such path.

I set this as critical since it results in data loss.

Reproducible: Always

Steps to Reproduce:
1. Upload a file with the character "达", a Chinese (simpified) character
2. As a control, copy that file and remove it to something safe, e.g. English name
3. Upload them together

Actual Results:  
The character "达" is replaced witj "_".
The file size of that file becomes zero.

Expected Results:  
Same result as the control file.
(Reporter)

Updated

12 years ago
Keywords: dataloss
(Reporter)

Comment 1

12 years ago
Change the character encoding of this page to "UTF-8" to see the character "达".

Updated

12 years ago
Summary: Empty file and wrong file name when the file name contains certian characters → Empty file and wrong file name when the file name contains certain characters
Depends on: 273225

Comment 2

11 years ago
*** Bug 327281 has been marked as a duplicate of this bug. ***

Comment 3

11 years ago

*** This bug has been marked as a duplicate of 66041 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.