Forcing user to recreate profile is not user friendly

RESOLVED INVALID

Status

()

Toolkit
Startup and Profile System
RESOLVED INVALID
12 years ago
9 years ago

People

(Reporter: db, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

I just had a weird problem with a site and tried to resolve it by disbling all
my extensions (≈6). This failed with a problem similar to
<https://bugzilla.mozilla.org/show_bug.cgi?id=266965>. I then tried to manually
remove the extensions according to the instructions at
<http://kb.mozillazine.org/Firefox_:_FAQs_:_Uninstall_Extensions> but this also
failed and now FF refused to start forcing me to recreate the profile. I have
backups and everything but it is still a mess to merge two profiles, requiring a
lot of restarts of FF to see if it works with the file you just added.

I think this "recreate profile" is user unfriendly and should be improved.
Furthermore, the concept of profiles on multiuser system is also user unfriendly
and just adds confusion. The random string in the profile catalog name (and in
the extension folder names) are also a mess (just look at the "manually
uninstall extension" instructions linked above to realize the confusion caused
by "random names that don't make any sense").

The bottom line:

* Completely recreate a profile should never be necessary.

* If _one_ settings or similar file gets corrupted Firefox/Mozilla/TB should be
able to verify its integrity and pinpoint out to the user "the file XXX.js or
ABC.rdf or 123.xml" does not look like a valid whatever-file.

In this situation the user should be able to either restore a backup or have the
program to recreate the file with default settings. In some cases, the program
should be able to recreate the file with the user's special settings, for
example, wouldn't it be possible to recreate the extension index by looking at
the files and folders in the extension directory?

* Maybe the program should have a function to support merging two settings folders?

* Simplify the whole concept of profiles. Is this concept user by any other
programs aimed at mulituser environments? Isn't it just an unnecessary layer of
abstraction?

Reproducible: Always
Multiple profile support is only there to aid developers and testers, an end
user should (and is not intended to) have to deal with profiles.

What do you mean by this "recreate profile", firefox does not ask you to
recreate you profile. Users are not forced to recreate their profile, users
should start firefox in safe mode when they experience extension problems.

>* Maybe the program should have a function to support merging two settings
>folders?
This does not make sense when you then say simplify the whole concept of profiles.

The main problem is the files becoming corrupted in the first place and any bugs
relating to not being able to sucessfully remove a problem extension in safe
mode. The intention is to fix these bugs so that issues such as this become
irrelevant.

If there are bugs relating to data corruption or loss, or extension installation
issues then these should be filed seperatly.
too many issues for one bug and some are worked on in separate bugs
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.