select box onchange not raised if select box has focus and item is selected by the first character

RESOLVED DUPLICATE of bug 126379

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 126379
12 years ago
12 years ago

People

(Reporter: t1t2t3t4, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050710 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050710 Firefox/1.0+

The page www.maersk-air.com has a booking module on the rigth side. 

The dropdown list does not raise the onchange event by pressing the leading
charqacter in one of the options in the list before the onchange event has been
activated with the mouse once. 
If the onchange event has been activated with the mouse, then the onchange event
occurs everytime as it is supposed to, even with pressing the leading character
in the options.

It's is a bug ... fix it! please

Reproducible: Always

Steps to Reproduce:
1. enter www.maersk-air.com in the address bar and press enter
2. Set focus on the first dropdown using the mouse.
3. Press D -> Denmark is selected.
Actual Results:  
The onchange event for the select box did not occurr, and hence the second
dropdown did not populate as it is supposed to do.

Expected Results:  
The onchange event should occurr causing my javascript to populate the second
dropdown.

This might be a variation of bug no. 126379

Comment 1

12 years ago
> The dropdown list does not raise the onchange event by pressing the leading
> character in one of the options in the list

That's bug 126379.

> If the onchange event has been activated with the mouse, then the onchange event
> occurs everytime as it is supposed to, even with pressing the leading character
> in the options.

I'm not experiencing this with Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O;
en-US; rv:1.8b4) Gecko/20050807 Firefox/1.0+.  Instead, when I use the keyboard
to select an item, onChange doesn't seem to fire until I move focus (regardless
of whether I've used the mouse to select an item previously).  How are you
determining that the onChange event has occurred?  I'm determining it by looking
at whether selecting "Select Departure Country" grays the second dropdown.

Comment 2

12 years ago

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.