Closed Bug 303902 Opened 14 years ago Closed 14 years ago

Firefox spins hogging 100% of CPU shortly after loading page - javascript

Categories

(Core :: DOM: Core & HTML, defect, major)

x86
All
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 335256

People

(Reporter: mozbugs, Unassigned)

References

()

Details

(Keywords: hang)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

After opening this page, it looks fine apart from the iframe at the bottom which
should be be in the left hand column. But if you click on any links, or slide
the scrollbar, oreven just leave the page be, firefox starts spinning hogging
near 100% of the cpu

Reproducible: Always

Steps to Reproduce:
1. Visit www.cfds.it
2. Click on link, scroll the scroll bar or wait a few seconds
3.
Actual Results:  
Firefox hangs using 100% of cpu

Expected Results:  
Page linked to should be displayed or page rendered scrolled appropriately

Page looks fine in Opera 8.02 on Linux, but the same problem occurs with Mozilla
1.7.10. It is apparent on a fully-updated RH WS3 and CentOS 4 boxes. strace-ing
the rogue process shows:

futex(0x993acc0, FUTEX_WAKE, 1)         = 1
futex(0x993acbc, FUTEX_WAKE, 1)         = 1
gettimeofday({1123516290, 441563}, NULL) = 0
stat64("/etc/localtime", {st_mode=S_IFREG|0644, st_size=1323, ...}) = 0
stat64("/etc/localtime", {st_mode=S_IFREG|0644, st_size=1323, ...}) = 0
stat64("/etc/localtime", {st_mode=S_IFREG|0644, st_size=1323, ...}) = 0
stat64("/etc/localtime", {st_mode=S_IFREG|0644, st_size=1323, ...}) = 0
stat64("/etc/localtime", {st_mode=S_IFREG|0644, st_size=1323, ...}) = 0
stat64("/etc/localtime", {st_mode=S_IFREG|0644, st_size=1323, ...}) = 0
gettimeofday({1123516290, 445780}, NULL) = 0
gettimeofday({1123516290, 446136}, NULL) = 0
gettimeofday({1123516290, 446414}, NULL) = 0
gettimeofday({1123516290, 454094}, NULL) = 0
gettimeofday({1123516290, 454416}, NULL) = 0
gettimeofday({1123516290, 454692}, NULL) = 0

being repeated over and over again,
Fails also trunk XP Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
Gecko/20050808 Firefox/1.0+

NOTE - URL has "Non utilizzare Firefox." - they they know there is a problem?

Javascript console error 
  "unknown property 'mso-style-parent'. Declaration dropped.
http://www.cfds.it/cfds1.htm   Line: 16"

consumes about 50k/sec
no hang with javascript disabled.
renders and appears to function fine in IE.
IF it's not an error by author, probably core. Dup of Bug 298852?
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: General → JavaScript Engine
Ever confirmed: true
Keywords: hang, mlk
OS: Linux → All
Product: Firefox → Core
Summary: Firefox spins hogging 100% of CPU shortly after loading page → Firefox spins hogging 100% of CPU shortly after loading page - javascript
Version: unspecified → Trunk
This page has an onload handler that calls itself via setInterval thus forking ever more increasing copies of the function. They should use setTimeout instead of setInterval. This is DOM 0 not JS Engine. I think their are probably bugs related to this but I didn't see them in a quick look. This could just as easily go to Tech Evang.
Assignee: nobody → general
Component: JavaScript Engine → DOM: Level 0
QA Contact: general → ian
Whiteboard: DUPEME
This doesn't actually leak memory, does it?
Keywords: mlk
Also, dupe of bug 261633

*** This bug has been marked as a duplicate of 261633 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.