legal_bugs_status should be spelled legal_bug_status in Bug.pm

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: ryan.gorsuch, Assigned: Olav Vitters)

Tracking

unspecified
Bugzilla 2.18
Bug Flags:
approval +
approval2.20 +
approval2.18 +

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; MRA 4.1 (build 00975); .NET CLR 1.0.3705)
Build Identifier: Bugzilla/2.18.3

In the file Bugzilla/Bug.pm, in the sub choices(), the hash $self->{choices}->
{bug_status} is set to the keyword @::legal_bugs_status which is a misspelling, 
and should be corrected to be @::legal_bug_status.

Reproducible: Always

Steps to Reproduce:
1. See the details for the location of this bug
(Assignee)

Comment 1

13 years ago
Confirmed in CVS HEAD.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

13 years ago
Created attachment 192000 [details] [diff] [review]
Patch v1 against Bugzilla 2.18 branch

Trivial patch for Bugzilla BUGZILLA-2_18-BRANCH. Does not apply to 2.20 branch
/ HEAD. The legal_bug_status is only used for provide the choices hash (in 2.18
Bug.pm, didn't check others). The choices.bug_status does not seem to be used
in any template.
Assignee: create-and-change → bugzilla-mozilla
Status: NEW → ASSIGNED
Attachment #192000 - Flags: review?(mkanat)

Comment 3

13 years ago
Comment on attachment 192000 [details] [diff] [review]
Patch v1 against Bugzilla 2.18 branch

r=LpSolit

please submit a patch for 2.20/tip
Attachment #192000 - Flags: review?(mkanat) → review+

Updated

13 years ago
OS: Windows 2000 → All
Hardware: PC → All
Target Milestone: --- → Bugzilla 2.18
(Assignee)

Comment 4

13 years ago
Created attachment 192607 [details] [diff] [review]
Patch for 2.20 branch and tip (both updated 13 Aug 2005)

Patch for 2.20 and tip. Patch was made for 2.20 branch, but applies cleanly
(only line offset warning) to tip.
Attachment #192607 - Flags: review?(LpSolit)

Comment 5

13 years ago
Comment on attachment 192607 [details] [diff] [review]
Patch for 2.20 branch and tip (both updated 13 Aug 2005)

r=LpSolit
Attachment #192607 - Flags: review?(LpSolit) → review+

Updated

13 years ago
Flags: approval?
Flags: approval2.20?
Flags: approval2.18?
Just to clarify (since it's not mentioned anywhere on the bug, and I had to ask
on IRC before I got it), this is not just a misspelling, it's referencing a
non-existent variable because of the misspelling, thus always getting an empty
list.  Correcting the spelling makes it reference the existing variable, and
actually show a result.  So this is actually correcting a bug, and not just
fixing a spelling mistake.
Flags: approval?
Flags: approval2.20?
Flags: approval2.20+
Flags: approval2.18?
Flags: approval2.18+
Flags: approval+

Comment 7

13 years ago
tip:

Checking in Bugzilla/Bug.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Bug.pm,v  <--  Bug.pm
new revision: 1.88; previous revision: 1.87
done

2.20rc2:

Checking in Bugzilla/Bug.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Bug.pm,v  <--  Bug.pm
new revision: 1.81.2.1; previous revision: 1.81
done

2.18.3:

Checking in Bugzilla/Bug.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Bug.pm,v  <--  Bug.pm
new revision: 1.37.2.5; previous revision: 1.37.2.4
done
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.