Acrobat plugin gives "File does not begin with '%PDF-'."

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: meier.kristian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

The follwing url is an example when the acrobat reader plugin gives a popup with
gives "File does not begin with '%PDF-'.":http://www.german.dhamma.org/kunst.pdf

if I set the property (in about:config) 'network.http.accept-encoding' to
'deflate' (instead of 'gzip,deflate') the plugin works fine. 

when I look on the server than I realise that the server is indeed gzipping the
the file, iff the Accept-Encoding header is set to gzip.

other servers which do not gzip pdf files are working fine the Acrobat-reader
plugin.

I have seen this at least from version firefox 1.0.4 onwards and with the old
and new Acrobat Reader plugin (5.x + 7.x) and I now people who have the same
experience on Firefox 1.0.4 > on Windows platform.

Reproducible: Always

Steps to Reproduce:
1.having acrobat reader plugin installed
2.open the url http://www.german.dhamma.org/kunst.pdf
3.

Actual Results:  
I see popup with the text: "File does not begin with '%PDF-'."

Expected Results:  
opened the pdf-file
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10)
Gecko/20050803 Firefox/1.0.6, Acrobat 7.0.0

WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050808
Firefox/1.0+
Firefox1.0.X is to old to report bugs. Please retest with a current trunk build.
This should be already fixed (could be bug 300438).

marking wfm, please reopen if you see this with current Trunk build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Hi,

I've been experiencing a slightly different problem than Kristian in Firefox
V1.0.6 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10).  I get a popup error
message "Loading of
file:///home/whn/.mozilla/firefox/rjvzog4v.default/Cache/81F00279d01 failed. 
The PDF file is damaged or it is not a PDF file. It could not be repaired" which
I understand comes from Adobe Acrobat Reader plugin.

I downloaded the nightly build (aka Deer Park Alpha 2)and was not able to figure
out how to get the Adobe Acrobat Reader plug-in to work with Deer Park.  How do
I do this?

Having Deer Park Alpha 2 nightly build running Acrobat Reader (not plugin) did
work.  Hope this helps.  Thanks Bill
You need to log in before you can comment on or make changes to this bug.