If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

WebEQ viewer control applet crashes Firefox when typing into any text field

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: naugustus, Unassigned)

Tracking

({crash})

1.0 Branch
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

The presence of the WebEQ viewer control applet on a page causes text input to
any element on that page to crash the browser. The crash occurs on the first
key-stroke when the focus is in a field that accepts input.

I can repeat this problem at will on:

OS      : Mac OS X 10.4.2
Browser : Firefox 1.0.6
Java    : 1.3.1_15

Problem and System Information from OS is attached.

Reproducible: Always

Steps to Reproduce:
1.Go to this page:
http://www.dessci.com/en/products/webeq/interactive/viewerctrlex.htm
2.Wait for the applet to finish loading and then try to type something in the
search text input field on the left menu. 
3.

Actual Results:  
The first key-stroke crashes the browser.

Expected Results:  
The presence of the WebEQ Viewer control applet on a page should not affect text
input fields.

-This problem is NOT seen when using Java 1.4.2 or Java 5 through the Java
Embedding Plugin.
-This problem is NOT seen on Mac OS X 10.3.9 / Firefox 1.0 / Java 1.3.1 or in
any Windows configuration.
(Reporter)

Comment 1

12 years ago
Created attachment 192010 [details]
System and Problem Description from Mac OS X

Updated

12 years ago
Severity: normal → critical
Keywords: crash
Version: unspecified → 1.0 Branch

Comment 2

10 years ago
works for me. 

I visited page (http://www.dessci.com/en/products/webeq/interactive/viewerctrlex.htm)
  and typed 'some word' in search text input field. 
but works fine. 

tested under 
  firefox 2.0.0.7
  Minefield/3.0a9pre

Comment 3

9 years ago
Confirmed working in Firefox 3.0.1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.