Version number reporting (client sniffer)

VERIFIED DUPLICATE of bug 30602

Status

()

P3
normal
VERIFIED DUPLICATE of bug 30602
19 years ago
17 years ago

People

(Reporter: janjaap, Assigned: vidur)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
this code reports the wrong version number:

if ((navigator.appName.indexOf('Netscape') != -1) &&
    (navigator.appVersion.substr(0, 1) > 3)) {
  document.write(' ');
}
else if ((navigator.appName.indexOf('Microsoft') != -1) &&
    (navigator.appVersion.substr(0, 1) > 3)) {
  document.write(' ');
  }
else
  {
  document.write('Not a version 4 browser');
}

thanks
JanJaap

Comment 1

19 years ago
Guessing that the problem here is that 'Netscape' does not appear in
navigator.appName.indexOf since you must have been testing a Mozilla,
not a Netscape, browser.

janjaap@x-stream.nl, what version of mozilla were you trying?

Check the resources at http://sites.netscape.net/ekrock/answers.html#areyouready
-- a Nav5/IE5-ready client sniffer is available there.
Assignee: rickg → vidur
Component: HTML Element → DOM Level 0
QA Contact: petersen → desale
Summary: Version number reporting → Version number reporting (client sniffer)

Comment 2

19 years ago
That should be changed back soon.

*** This bug has been marked as a duplicate of 30602 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 3

19 years ago
Is this a duplicate? Bug 30602 concerns the commercial Netscape build. This 
concerns the Mozilla builds.

Comment 4

19 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED

Comment 5

17 years ago
Mass removing self from CC list.

Comment 6

17 years ago
Now I feel sumb because I have to add back. Sorry for the spam.
You need to log in before you can comment on or make changes to this bug.