Causes 99% cpu when loading a large apache web directory listing

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
14 years ago
12 years ago

People

(Reporter: joshua, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Load any directory listing that is fairly large (1000+ files in the listing).
The CPU will go to 99% for a varying amount of time. This is confirmed to be a
firefox only bug as it doesnt happen in konqueror, opera, or IE.

Reproducible: Always

Steps to Reproduce:
1. Open the sample URL

Actual Results:  
99% cpu for 20-30 seconds

Expected Results:  
no high cpu usage

Comment 1

14 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050808 Firefox/1.0+
ID:2005080814

I see the same CPU usage in Firefox and in Opera. Possibly the page was cached
in Opera and IE.

Comment 2

13 years ago
The URL is gone.
Resolving this as invalid.

The url that was provided to reproduce this bug results since a while in a 404 Error. 

Joshua, if you still can reproduce this bug, feel free to reopen this bug, please provide a testcase or url then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
Version: unspecified → 1.0 Branch
(Reporter)

Comment 4

12 years ago
Gee, a url is invalid after 2 years of remaining open. Go mozilla team! I wont bother reposting a url as this just removed me as a firefox user. Thanks!
You need to log in before you can comment on or make changes to this bug.