[PatchReader] Extend Patch Viewer functionality to Subversion

RESOLVED WONTFIX

Status

()

Bugzilla
Attachments & Requests
--
enhancement
RESOLVED WONTFIX
13 years ago
3 years ago

People

(Reporter: Shailesh Kochhar, Assigned: timello)

Tracking

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Bugzilla patch viewer has the ability to view patches in formatted form that is
easier to deal with and handle than raw code. Currently the patch viewer
interfaces with bonsai, cvs and lxr to extract current versions from source
control. It would be beneficial to extend this ability to include subversion and
other version control servers as well.

Reproducible: Always
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

12 years ago
we sometimes accept patches.
Keywords: helpwanted
(Reporter)

Comment 2

12 years ago
I'm willing to work on this, but I don't have any experience with the bugzilla codebase so I'd need to work with someone on it to get going.

Comment 3

12 years ago
Bug 342075 might be related to this, at least from an implementation point of view, as it was suggested by mkanat in comment #3 to implement such functionality using the proposed XML/RPC (Bug 224577) backend for various sorts of feature delegation or interfacing. 
So, more generally this might probably be better described as "standard VCS interface"?

Updated

11 years ago
Summary: Extend Patch Viewer functionality to Subversion → [PatchReader] Extend Patch Viewer functionality to Subversion
(Assignee)

Comment 4

6 years ago
Created attachment 588200 [details] [diff] [review]
v1
Assignee: attach-and-request → timello
Status: NEW → ASSIGNED
Attachment #588200 - Flags: review?(wicked)
(Assignee)

Comment 5

6 years ago
Created attachment 588201 [details] [diff] [review]
PatchReader SVN support

I will probably going to submit it to rt.cpan.
Attachment #588201 - Flags: review?(wicked)
(Assignee)

Comment 6

6 years ago
Created attachment 588203 [details] [diff] [review]
v2
Attachment #588200 - Attachment is obsolete: true
Attachment #588203 - Flags: review?(wicked)
Attachment #588200 - Flags: review?(wicked)
Comment on attachment 588201 [details] [diff] [review]
PatchReader SVN support

Thanks for this patch! I'm adding it to the PatchReader module and it will be in the next version. If you don't mind, I'll modify the changes as needed to fit into PatchReader and hopefully add some specific tests.

>--- PatchReader-0.9.6/SVNClient.pm	1969-12-31 21:00:00.000000000 -0300
>+++ PatchReader-0.9.7/SVNClient.pm	2012-01-12 20:44:46.000000000 -0200
>@@ -0,0 +1,34 @@
>+# The contents of this file are subject to the Mozilla Public
>+# License Version 1.1 (the "License"); you may not use this file

Any chance you could license this file with Artistic license, because that's the license used for the bulk of the PatchReader. If you want MPL, then would you mind if we do MPL v2 instead because that's what Bugzilla is licensed with these days..

>+# The Initial Developer of the Original Code is Netscape Communications
>+# Corporation. Portions created by Netscape are
>+# Copyright (C) 2003 Netscape Communications Corporation. All
>+# Rights Reserved.

Seriously? Netscape contributed something for this file? :)
Attachment #588201 - Flags: review?(wicked)
(Assignee)

Comment 8

6 years ago
(In reply to Teemu Mannermaa (:wicked) from comment #7)
> Comment on attachment 588201 [details] [diff] [review]
> PatchReader SVN support
> 
> Thanks for this patch! I'm adding it to the PatchReader module and it will
> be in the next version. If you don't mind, I'll modify the changes as needed
> to fit into PatchReader and hopefully add some specific tests.

Sure! Feel free to change it if needed!

> 
> >--- PatchReader-0.9.6/SVNClient.pm	1969-12-31 21:00:00.000000000 -0300
> >+++ PatchReader-0.9.7/SVNClient.pm	2012-01-12 20:44:46.000000000 -0200
> >@@ -0,0 +1,34 @@
> >+# The contents of this file are subject to the Mozilla Public
> >+# License Version 1.1 (the "License"); you may not use this file
> 
> Any chance you could license this file with Artistic license, because that's
> the license used for the bulk of the PatchReader. If you want MPL, then
> would you mind if we do MPL v2 instead because that's what Bugzilla is
> licensed with these days..

It can be Artistic license or MPL v2. You choose.

> 
> >+# The Initial Developer of the Original Code is Netscape Communications
> >+# Corporation. Portions created by Netscape are
> >+# Copyright (C) 2003 Netscape Communications Corporation. All
> >+# Rights Reserved.
> 
> Seriously? Netscape contributed something for this file? :)

Haha, nothing at all :)

Thanks wicked!
(Assignee)

Comment 9

5 years ago
Hey wicked,

Any chance to review this patch and update PatchReader with the SVN support?

Comment 10

3 years ago
Comment on attachment 588203 [details] [diff] [review]
v2

We removed all CVS-specific code from Bugzilla, see bug 1068494. At this point, there is no plan to add SVN, which isn't much more popular these days.
Attachment #588203 - Flags: review?(wicked) → review-

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Keywords: helpwanted
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.