<td background="image_name_here.ext"> HTML: TD background image tag not displaying image in browser.

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Eric, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050808 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050808 Firefox/1.0+

<td background="image_name_here.ext"> HTML background image tag for table
details are displayed as a blank area on page with all content missing with-in
the affected table.

Reproducible: Always

Steps to Reproduce:
1.Visit: http://www.artforhumanity.org/
2.Same code works in IE for Mac and PC




Expected Results:  
Read tag and produce the image display.
(Reporter)

Comment 1

13 years ago
UPDATE: Just tried .gif td background image with success, .jpg images produce
the bug.

Comment 2

13 years ago
The page http://www.artforhumanity.org/ contains several TABLEs and TDs.
If you mean the table containing the text "About Art For Humanity",
the table is missing because it is commented out.
(Reporter)

Comment 3

13 years ago
Created attachment 192112 [details]
Original html doc with comment tags as coded.
(Reporter)

Comment 4

13 years ago
Created attachment 192113 [details]
Comment tag issues here as well.
(Reporter)

Comment 5

13 years ago
I removed all comment tags from the posted index page, and the background images
do appear. However, to the best of my knowledge the comment tags are being
re-written in the browser. Attached is the index file as it was originally
coded, and as you can see, the comment tag was properly closed out.

Also attached is original code for a page that I have left on line as is. If you
compare the love doc to the attached one, you can see where it does appear to be
re-written.

http://www.artforhumanity.org/you-can-help.htm
Please URL compare source to attachment.
(Reporter)

Comment 6

13 years ago
Specifically, the comment tag for http://www.artforhumanity.org/you-can-help.htm

<!-------------------------------------->
<!--------------Foot Nav---------------->
-------------------------------------->

Has been re-written from the original:

<!-------------------------------------->
<!--------------Foot Nav---------------->
<!-------------------------------------->

On the index page previously attached, the comment tags that were closed on the
document, were open on the live page when accessed through the browser. Those
tags have been removed now, but I replicated the issue by loading the
attachments into the browser locally.
this is not a forum for html errors.
proper validation would have pointed you at your mistakes
http://validator.w3.org/check?uri=http%3A//www.artforhumanity.org/you-can-help.htm

->INVA
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.