Crash going back on thottbot.com

VERIFIED DUPLICATE of bug 304003

Status

()

--
critical
VERIFIED DUPLICATE of bug 304003
13 years ago
10 years ago

People

(Reporter: darin.moz, Assigned: bryner)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Navigate to:  http://thottbot.com/?iclass=2.0
Hover over one of the images that cause a floating DIV to appear, and then
click, which should cause the browser to navigate to the corresponding link. 
Then, press the back button, and then bad things happen.  The page does not get
restored.  This assertion is hit:

###!!! ASSERTION: RestoreFromHistory failed: 'NS_SUCCEEDED(rv)', file
/builds/moz-trunk/mozilla/docshell/base/nsDocShell.cpp,
line 4935

Then, sometimes there is a crash... perhaps when JS GC runs.

I just noticed this with today's build: 8/9/2005 on Linux.
(Reporter)

Comment 1

13 years ago
Created attachment 192148 [details]
valgrind trace
does that build have bug 304003's patch?
(Reporter)

Comment 3

13 years ago
It's possible that it does not.  I'm updating my tree now to see if this bug is
still reproducible.
(Reporter)

Comment 4

13 years ago
Yup, I believe this is a duplicate.

*** This bug has been marked as a duplicate of 304003 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: history.session → docshell
You need to log in before you can comment on or make changes to this bug.