Content Length of google.src is incorrect

RESOLVED WORKSFORME

Status

()

Firefox
Search
--
trivial
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: O. Atsushi (Torisugari), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
This is not a firefox bug.
Google does not return proper HTTP response header.

Steps to reproduce:
1. Go to http://www.google.com/mozilla/google.src 
2. Check the content-length ([Tools]->[Page Info]). it claims 343 bytes. 
3. Save the .src in the local disk (save page as...)
4. Confirm saved file size (707 bytes)

The problem is, wrong content length triggers update event,
because the browser assumes that plugin must already be obsolete.
Eventually, most of Firefox/Seamonkey users keep updating the plugin
*almost everyday* though nothing actually changed.

There's no way to stop such a silly update.

Comment 1

13 years ago
This is probably related to bug 121616, since the content is gziped.
http://leknor.com/code/gziped.php?url=http://www.google.com/mozilla/google.src
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> This is probably related to bug 121616, since the content is gziped.
> http://leknor.com/code/gziped.php?url=http://www.google.com/mozilla/google.src

Ah. It makes sense.
That's not only a pageinfo problem. I'm quite sure you can find a entry

NSXXX:LastPingContentLen="343"

in your localstore.rdf. And the searchservice compares the ContentLength
with string length in a strange way.

Updated

13 years ago
No longer depends on: 271097
The search service update system no longer relies on the reported filesize, so there's nothing left here other than bug 121616.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.