The default bug view has changed. See this FAQ.

Junk/scam header pane remains after selection of an empty folder (i.e. no message selection)

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: stephend, Assigned: Ian Neal)

Tracking

({regression, verified1.8})

Trunk
regression, verified1.8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

12 years ago
Build ID: 2005-08-08-09-05, Windows XP SeaMonkey trunk.

Steps to Reproduce:

1. Empty your Trash folder ahead of time.
2. Select a message in a different folder.
3. Ensure a message is marked as Junk or a Scam.
4. Now select the Trash folder.

Expected Results:

The window title and window body are cleared, since no message is
selected/displayed.

Actual Results:

The scam/junk bar header pane is left until you select a new message without
either of those.
(Reporter)

Updated

12 years ago
Summary: Junk/scam header pane remains selection of an empty folder (i.e. no message selection) → Junk/scam header pane remains after selection of an empty folder (i.e. no message selection)
(Reporter)

Comment 1

12 years ago
Just wanted to make this more clear:

Steps 2 and 3 are not really separate messages; just separate steps on the
*same* message.
(Assignee)

Comment 2

12 years ago
Patch coming up.
Status: NEW → ASSIGNED
Keywords: regression
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 3

12 years ago
Created attachment 192195 [details] [diff] [review]
Patch v0.1

This patch:
* Fixes the problem when aIndex is set to kMsgNotificationNoStatus - we need to
completely clear any status and hide the Notification bar, so lets do that
instead of faffing about only do other stuff when it's not set to that.

Stephen, can you make sure this fixes the problems you have seen, it seems to
have for me.
(Assignee)

Updated

12 years ago
Attachment #192195 - Flags: review?(neil.parkwaycc.co.uk)
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> Stephen, can you make sure this fixes the problems you have seen, it seems to
> have for me.

As already mentioned on IRC, this fixes the problem for both Howard Chu and me.
(Assignee)

Updated

12 years ago
Attachment #192195 - Flags: review?(neil.parkwaycc.co.uk)
(Assignee)

Comment 5

12 years ago
Created attachment 192365 [details] [diff] [review]
Revised patch v0.1b

This patch:
* Re-orders the decks in the msgNotificationBar so they are in precedence order

* Makes clearMsgNotifications do just that :-)
Attachment #192195 - Attachment is obsolete: true
Attachment #192365 - Flags: review?(neil.parkwaycc.co.uk)

Comment 6

12 years ago
Comment on attachment 192365 [details] [diff] [review]
Revised patch v0.1b

Nit: you're not using mBarFlagValues[0] or kMsgNotificationNoStatus so you can
get rid of them and the empty hbox.
Attachment #192365 - Flags: review?(neil.parkwaycc.co.uk) → review+
(Assignee)

Comment 7

12 years ago
Created attachment 192387 [details] [diff] [review]
Tweaked patch v0.1c (Checked in on trunk and branch)

Changes since v0.1b
* Removed unneeded kMsgNotificationNoStatus

I'm happier leaving mBarFlagValues[0] alone as it keeps things simplier

Carrying r= forward and requesting sr=
Attachment #192365 - Attachment is obsolete: true
Attachment #192387 - Flags: superreview?(bienvenu)
Attachment #192387 - Flags: review+

Updated

12 years ago
Attachment #192387 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Comment 8

12 years ago
Comment on attachment 192387 [details] [diff] [review]
Tweaked patch v0.1c (Checked in on trunk and branch)

Requesting a= for this regression fix
Attachment #192387 - Flags: approval1.8b4?
(Assignee)

Comment 9

12 years ago
Comment on attachment 192387 [details] [diff] [review]
Tweaked patch v0.1c (Checked in on trunk and branch)

Checking in (trunk)
mailWindowOverlay.js;
new revision: 1.223; previous revision: 1.222
mailWindowOverlay.xul;
new revision: 1.299; previous revision: 1.298
done
Attachment #192387 - Attachment description: Tweaked patch v0.1c → Tweaked patch v0.1c (Checked in on trunk only)
(Assignee)

Updated

12 years ago
Flags: blocking-seamonkey1.0a?
Whiteboard: [awaiting a=]

Updated

12 years ago
Attachment #192387 - Flags: approval1.8b4? → approval1.8b4+
(Assignee)

Comment 10

12 years ago
Comment on attachment 192387 [details] [diff] [review]
Tweaked patch v0.1c (Checked in on trunk and branch)

Checking in (branch)
mailWindowOverlay.js;
new revision: 1.222.2.1; previous revision: 1.222
mailWindowOverlay.xul;
new revision: 1.298.2.1; previous revision: 1.298
done
Attachment #192387 - Attachment description: Tweaked patch v0.1c (Checked in on trunk only) → Tweaked patch v0.1c (Checked in on trunk and branch)
(Assignee)

Updated

12 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Whiteboard: [awaiting a=]
(Assignee)

Updated

12 years ago
Flags: blocking-seamonkey1.0a?
Keywords: fixed1.8
(Reporter)

Comment 11

12 years ago
Verified FIXED on _trunk_ build 2005-08-16-12 using Windows XP SeaMonkey.

(Note that branch verification would need verified1.8 as a keyword to replace
fixed1.8.)
Status: RESOLVED → VERIFIED

Comment 12

12 years ago
Also verified is a self-built branch build with the following UA:
Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.8b4) Gecko/20050817 SeaMonkey/1.0a
Keywords: fixed1.8 → verified1.8
You need to log in before you can comment on or make changes to this bug.