Closed Bug 304145 Opened 16 years ago Closed 13 years ago

After undoing a complete deletion of the 'name' field, the 'Add' button remains disabled

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set
minor

Tracking

()

RESOLVED INVALID

People

(Reporter: maeth, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

This bug prevents the user from adding a bookmark after he undid a deletion of
the name field in the 'Add bookmark' dialogue by mistake.

Reproducible: Always

Steps to Reproduce:
1. Press CTRL+D or select Bookmarks->Add Bookmark to pop up the 'Add Bookmark'
dialogue.
2. The name field contains the current page title, it is completely highlighted.
Press DEL or use the context menu to delete it. 
3. Press CTRL+Z or use the context menu for an undo.

Actual Results:  
After step 2, the 'Add' button is disabled, which is the anticipated behavior.
But after undoing the deletion of the field, it is still disabled until
something is entered.

Expected Results:  
Firefox should enable the button everytime when there's some text in the 'Name'
field.

Reproducable under:
- Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.10) Gecko/20050717
Firefox/1.0.6
- Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
- FF 1.0.6 under Linux

Therefore, I assume this bug being included in almost every Firefox version.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050811
Firefox/1.0+ ID:2005081104

I see the same.

> After step 2, the 'Add' button is disabled, which is the anticipated behavior.
> But after undoing the deletion of the field, it is still disabled until
> something is entered.

One space is enough. :) 


OS: Linux → All
Hardware: PC → All
*** Bug 316056 has been marked as a duplicate of this bug. ***
Depends on: 318065
invalid on current trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20081215 Minefield/3.2a1pre
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.