Closed Bug 304176 Opened 17 years ago Closed 17 years ago

First launch account creation doesn't honor unchecking [ ] Download messages now option

Categories

(SeaMonkey :: MailNews: Account Configuration, defect)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ajschult784, Assigned: neil)

Details

(Keywords: dataloss, fixed1.8)

Attachments

(2 files)

As described in bug 270743, messages are downloaded from a pop server after
account creation even if the "download messages now" option is unchecked.  Since
the messages are deleted from the server by default, there is no way to set up
an account without deleting the existing messages.  It's possible the fix from
that bug would also work for SeaMonkey
Sorry, Andrew, but when I did search for this bug tonight, it didn't exist yet,
and so when I attached the patch to 270743, I didn't look for a bug again... :-/


*** This bug has been marked as a duplicate of 270743 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Let's back out bug 270343 and fix both bugs correctly.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Attached patch Proposed patchSplinter Review
There was a second, less noticable misuse of .msgFolder in
msgMail3PaneWindow.js which meant that a default pop3 server never got
downloaded by loadStartFolder.
Fixing that allows us to fix mailWindowOverlay.js not to download it instead.
We need mailWindowOverlay.js not to download the default server in case it's an
IMAP server in which case it will get downloaded when the inbox is selected.
I'll attach a -w diff in a sec as I think it might make it easier to review.
Assignee: mail → neil.parkwaycc.co.uk
Status: REOPENED → ASSIGNED
Attachment #192281 - Flags: superreview?(bienvenu)
Attachment #192281 - Flags: review?(mnyromyr)
Comment on attachment 192281 [details] [diff] [review]
Proposed patch

sorry for the delay - I was waiting for a -w diff, but this seems fine.
Attachment #192281 - Flags: superreview?(bienvenu) → superreview+
Attachment #192281 - Flags: review?(mnyromyr) → review+
Fix checked in to the trunk.
Status: ASSIGNED → RESOLVED
Closed: 17 years ago17 years ago
Resolution: --- → FIXED
Comment on attachment 192281 [details] [diff] [review]
Proposed patch

suite dataloss fix
Attachment #192281 - Flags: approval1.8b4?
Attachment #192281 - Flags: approval1.8b4? → approval1.8b4+
Keywords: fixed1.8
You need to log in before you can comment on or make changes to this bug.