New unread count of saved searches is 2x the actual messages.

RESOLVED FIXED

Status

Thunderbird
OS Integration
RESOLVED FIXED
13 years ago
8 years ago

People

(Reporter: tracy, Unassigned)

Tracking

(Blocks: 2 bugs)

Trunk
All
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
seen on recent Mac Thunderbird trunk builds

steps to reproduce:
-ensure all messages are Read in the account you will use for testing.
-create a saved search on the inbox for subject contains "popeye" (create it as
a subfolder to the account inbox)
-compose and send a message to that account with "popeye" in the subject
-Put focus in the Folders pane on the accout (not the inbox or saved search for
popeye)
-Click Get Mail

tested results:
As long as the test message is the only one downloaded, the follow shold be seen: 
The Inbox will indicate one new unread message : Inbox (1) (this is as expected)
The saved search folder will indicate two new unread messages : Inbox-popeye (2)

expected results: 
The test saved search folder should indicate one new unread messages :
Inbox-popeye (1)

note 1: clicking on the test saved search folder will correct the count from (2)
to (1).  
note 2: Click on the test save search folder, but don't read any popeye
messages, then receive a new message that meets the search criteria and the
count for the search folder will show (3) instead of (2) 

note 3: I can not reproduce this on Windows.
QA Contact: front-end

Comment 1

10 years ago
Tracy, do you still see this problem?
(Reporter)

Comment 2

10 years ago
I haven't seen this on 2.0.0.x branch. Which is all I've used of late.  I'll have to check trunk later.
This looks like bug 278945 which was marked a duplicate of bug 272060

Comment 4

10 years ago
Indeed, duping...
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 272060
(Reporter)

Comment 5

10 years ago
um, no.  

I filed this one months after that one was closed.  And happen to see it yesterday with T-bird version 2.0.0.12 (20080213)
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

10 years ago
Blocks: 438257

Updated

9 years ago
Assignee: mscott → nobody
Status: REOPENED → NEW

Comment 6

8 years ago
Created attachment 408764 [details]
Screenshot of bug 304190 - Thunderbird ver. 3b4.

Here is a screenshot of the bug in action.  This is Thunderbird version 3b4 on Mac OSX 10.5.8.  The blurs were added.

Comment 7

8 years ago
(In reply to comment #6)
> Created an attachment (id=408764) [details]
> Screenshot of bug 304190 - Thunderbird ver. 3b4.
> 
> Here is a screenshot of the bug in action.  This is Thunderbird version 3b4 on
> Mac OSX 10.5.8.  The blurs were added.

I believe my screenshot is of the same issue, or at least caused by the same issue, but I didn't follow the steps to reproduce as listed.

For the wrong number of new messages to be shown in the dock icon, the steps to reproduce are as follows:

1) Get a new message.
Blocks: 36011
Component: Mail Window Front End → OS Integration
QA Contact: front-end → os-integration
Hardware: PowerPC → All
If you could confirm this on a nightly build, I'd be interested.  I've just done some fixes that should address this.
(Reporter)

Comment 9

8 years ago
I can't reproduce with the nightly build from today (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.5pre) Gecko/20091029 Shredder/3.0pre)
Marking as fixed by bug 509163.  If this starts again, we can reopen or get a new bug going.  Thanks for testing.
Status: NEW → RESOLVED
Last Resolved: 10 years ago8 years ago
Depends on: 509163
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.