Opening attachments with non-ascii filenames shows corrupted file name

RESOLVED DUPLICATE of bug 234681

Status

RESOLVED DUPLICATE of bug 234681
13 years ago
13 years ago

People

(Reporter: madhancr, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: version 1.0.6 (20050716)

When an attachment with non-ascii filename is opened by double clicking on it, 
it shows as _____.txt on the title bar of notepad.

Reproducible: Always

Steps to Reproduce:
1.Send an email with an attachment containing non-ascii filename (をアクセシビ
リ.txt)
2. upon receiving, open the attachment by double-clicking on it.
3. Open it without saving to disk. Notice if it is a txt file, the notepad 
shows corrupted filename. 

Actual Results:  
________.________.txt on title bar of notepad. The file contents are good, 
just the name is corrupted

Expected Results:  
をアクセシビリ.txt on the title bar of notepad

The machine has Asian languages installed.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 234681 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Summary: Opening attachments with non-ascii filenames shows corrupted file name → Opening attachments with non-ascii filenames shows corrupted file name
You need to log in before you can comment on or make changes to this bug.