Spell check often doesn't offer a correct replacement for words misspelled beginning with two capital letters

RESOLVED WORKSFORME

Status

()

Core
Spelling checker
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: Ken, Assigned: Scott MacGregor)

Tracking

1.8 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Words such as "THe" and "THanks" are caught in spell check in Thunderbird, but
no suggestion is given.  The word must be retyped.

Reproducible: Always

Comment 1

13 years ago
version 1.0+ (20050808)

Works for me. Please test in the latest build:
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-trunk/
(Reporter)

Comment 2

13 years ago
Not sure what this email was about.  It seems you wanted me to upgrade and
retest.  I was using 1.0.5.  I upgraded to Alpha 2 (20050810), and tried the
same issue.  Although I received suggestions, none were correct.  (None offered
"Thanks" for "THanks" or "The" for "THe") 

Comment 3

12 years ago
Spellcheck will also ignore mistyped words like haven;t.

It never remembers or suggests diacriticals such as François, José or être.

It suggests lots of misspelled or inapproariate and nuseless words. How can one edit the dictionary? 

Same on Mac OSX and Windows 2k machines

Comment 4

12 years ago
Thunderbird version 1.5 (20051201) WinXP

This seems to be WFM in 1.5rc2

Comment 5

11 years ago
*** Bug 355017 has been marked as a duplicate of this bug. ***

Comment 6

11 years ago
*** Bug 337724 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Status: UNCONFIRMED → NEW
Component: General → Spelling checker
Ever confirmed: true
OS: Windows XP → All
Product: Thunderbird → Core
QA Contact: spelling-checker
Hardware: PC → All
Summary: spell check bugs → Spell check often doesn't offer a correct replacement for words misspelled beginning with two capital letters
Version: unspecified → 1.8 Branch

Comment 7

11 years ago
The spell checker that we is based on the OpenOffice one.  Some bugs that existed in the code we use have been resolved in the OpenOffice system (see for example bug 318040 comment #5).  Does that apply here as well?  If so, do we need to go back to their code and re-integrate?

Comment 8

11 years ago
The two most bothersome spellcheck capitalization problems in TB, and fortunately also easiest to fix:
words mistyped  with two INitial CApital LEtters and "i" for "I".  All the others don't bother me much, since they're so much less common.

I have OO-writer  2.02, and the spellcheck there catches and corrects two INitial CApital LEtters and "i" for "I" perfectly, so if their spellcheck  could be incorporated in TB, that would fix most of the capitalization problems!  Yay!!


(Would also help Bug 128122 RFE: Spell checker does not recognize capitalization errors & Bug 355331 spell checker should give more suggestion)

Comment 9

10 years ago
Spell Checker (including the version in FF 2.0.0.9) does weird
things with mis-capitalized words.

For Example: 
1) "WHen" returns "Wren, whens, hen, wen, then". Why isn't the obvious choice
of "When" presented?
Further were does this dictionary come from? "whens" is not an English word.
(When's could be considered a contraction of "when is" but that's about as
close as you get).

2) "SPell" returns "Snell, Shell, Skell, spell, ispell". This is closer, at
least we got "spell" in the list though not as the first choice and not with
proper capitalization.

Updated

10 years ago
Blocks: 413950
No longer blocks: 413950

Comment 10

10 years ago
Spell checker was optimized and bug fixed in the Firefox 3 Branch. And the latest Nightly of Thunderbird seems to be fixed to.

Anyone who can please check if this works for you by downloading Firefox 3 Beta 3 from here: http://www.mozilla.com/en-US/firefox/3.0b3/releasenotes/#download.

Bug is waiting for Resolve Status.
Verified to be fixed here, testing the works in this text field while writing this comment.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3 ID:2008020514

-Mike

Please mark resolution status. Bug is verified here by me in Firefox 3 Beta 3. (But I can not mark)

Comment 11

10 years ago
Mike, VERIFIED is used only *after* the bug gets RESOLVED to verify that the fix worked. (And it gets RESOLVED FIXED when relevant patches have been checked in.)

So, probably fixed by bug 413950. Marking WFM since I don't know for sure and may commenters say they never saw it in earlier versions...
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 12

10 years ago
*** VERIFIED as fixed. 
When I type in "CRomputer" the suggestion is Computer so it works and is fixed.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008030405 Minefield/3.0b5pre

Please mark as verified.

Thanks,
-Mike

Comment 13

10 years ago
Having that one word correct is no real indication of how badly it still functions. 

When I type in "Ccomputer" the suggestion is (you pick): computer, C computer, or c computer, and not Computer, so it doesn't work and it's not fixed. 

The Mozilla spellchecker is a pathetic joke. I think it needs to be thrown out entirely and replaced with an entirely different one. And the future one should be something users can access and edit, as was once possible with Netscape 4.7. 

Comment 14

10 years ago
I'm with Paul H on this, checking a single word is hardly a valid test for something this complex.

Comment 15

10 years ago
You are obviously not running trunk builds, no point commenting if you don't. (As in firefox3.0b3/b4/5pre or thunderbird3.0a1pre) 

If you had, you'd notice comment 13 is working properly.
You need to log in before you can comment on or make changes to this bug.