Downloaded files automatically opened in a new window don't show URL in address bar

RESOLVED DUPLICATE of bug 88567

Status

--
trivial
RESOLVED DUPLICATE of bug 88567
13 years ago
13 years ago

People

(Reporter: schapel, Assigned: jag-mozilla)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
Reproducible: Always

Steps to Reproduce:
1. Go to http://forums.invisionpower.com/lofiversion/index.php/t156847.html
2. Click on one of the zip build links in the third post

Expected Results: The link opens a new window, and the URL of the file is shown
in the address bar.
Actual Results: The link opens a new window, and the address bar is blank.

If you open the link by right-clicking and selecting Open Link in New Window,
the URL is displayed in the address bar as expected. The same thing happens when
browser.link.open_newwindow is set to 3, except a new tab is opened instead of a
new window. I've noticed this in SeaMonkey trunk builds for the past few weeks,
and can reproduce in trunk build 2005081005 on Windows XP SP2.

Comment 1

13 years ago
There are three ways that links can open in a new window (or tab).

The first is when you right-click it (or control-click it, given appropriate prefs). In this case, the UI opens the new window or tab with the given URL and is able to preload the URL bar. Note that this goes wrong in some cases, such as opening a link in a file to a file that does not exist.

The second is when the javascript window.open function is used. If the open is diverted into a window then in certain circumstances the UI will be given the URL and will preload the URL bar. However if the open is diverted into a tab, then although the UI gets to open the tab it bypasses the function that preloads the URL bar in order to avoid the issues mentioned above. At the time we took great care to duplicate Firefox's behaviour in this respect.

The third is when the link (or indeed a submitted form, possibly through the use of javascript) uses the target attribute to open in a new window. Even if the open is diverted into a tab, the UI is not told of the URL.
(Reporter)

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 88567 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.