Closed Bug 304251 Opened 17 years ago Closed 16 years ago

Download manager hung after many download and/or remove actions

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 240525

People

(Reporter: e_verybody, Unassigned)

Details

(Keywords: hang)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

I tried clicking remove on one item and then another after the previous one was
removed.  I did this many times and was never able to remove 30 in a row.  The
two or three times I actually counted I was able to remove 26 item and then
Firefox (both the browser and the download manager) crashed when I clicked on
the 27th one.  Next, after choosing "End now" from the 'Program not responding'
box and rebooting my machine for good measure, I reopened Firefox and the
download manager and removed 25 items.  I then download one file successfully. 
When I tried to download another (this being the 27th action for download
manager) Firefox and the download manager crashed again.

Reproducible: Always

Steps to Reproduce:
1. Download a lot of files (not sure if there is a total number that needs to be
exceeded before this happens) 
2. Do any combination of removing items from the download manager and/or
downloading files until you get up to 27.
3. I'm not absolutely sure that it's always the 27th one that fails, but it was
each time I counted and I'm sure I never got to 30.  
Actual Results:  
Firefox and the download manager quit responding.

Expected Results:  
It should have removed or downloaded the 27th item.

I typically have 10 tabs open from the time I start Firefox.
Keywords: crash
Summary: Download manager crashes after 26 download and/or remove actions → Download manager hangs after 26 download and/or remove actions
Summary: Download manager hangs after 26 download and/or remove actions → Download manager hung after 26 download and/or remove actions
Keywords: crashhang
Severity: critical → normal
Summary: Download manager hung after 26 download and/or remove actions → Download manager hung after many download and/or remove actions
Related to bug 273244?
I haven't examined if it's always the 27th removal, but the Download Manager
does cause my Firefox to lock up if I attempt to remove entries. 
It also takes a very long time to remove an entry when it doesn't hang the program.
I may have found the solution to this problem. If there are many files in the default download directory or it's subdirectories, then the download manager spins the cpu processing the download history information. Change the download directory to an empty directory and clean up the download history.
Looks like a duplicate of bug #240525.
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 240525
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.