If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Keeping links in sync over the internet.

RESOLVED DUPLICATE of bug 260301

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED DUPLICATE of bug 260301
12 years ago
12 years ago

People

(Reporter: Daniel Hedblom, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511

Im no coder but and avid Linux and Firefox/Mozilla user. I use almost ten
different computers on different networks over a normal day since i roam around
much in my work. One thing i find lacking is keeping my bookmarks avaliable
wherever i go. 

There are solutions that lets one manage the bookmarks online but its all done
by hand and not smooth at all. Adding bookmarks is a real PITA in all forms i
have tried. 

It would be extremely easy to setup a server to keep a list of users and their
respective html files with the links in them. Doing it in that way makes the
system accessible from any browser without any plugin. But, making a plugin that
adds and manages the links in firefox/mozilla would be very handy for many of
us. I havent seen any product like this so its perhaps patentable and if so i
gladly would let the OSS community have it.

My implementations would work like this:

The user has an account on a http or ftp server with read and write rights on a
file. The file is in normal html to make it useful without the plugin. That way
you can read it from anywhere and from any application capable of html. The tags
should just be normal link tags and nothing fancy. 

The plugin manages login to the http server, reads the html file and displays
the links in the bookmarks menu. After having added something the plugin should
save to the server the  changes. Adding links should be done in normal fashion
ie ctrl-d or by dragging and dropping them. The most important thing is to be
able to add bookmarks easily and securely. 

Maybe this have been done before and i havent been able to find it but its one
feture i think would give Firefox and Mozilla a leg up on IE, Opera and other
browsers. Sure you can use profiles but how often arent you on a network you
cant control? This system makes it possible to access the bookmarks from
anywhere you have an internet connection since they are in a plain html file. 

Best Regards

Daniel Hedblom


Reproducible: Always

Comment 1

12 years ago
You might look at solutions like :
- Bookmarks Synchronizer
<https://addons.mozilla.org/extensions/moreinfo.php?application=firefox&category=Bookmarks&numpg=10&id=14>
- Chipmark
<https://addons.mozilla.org/extensions/moreinfo.php?application=firefox&category=Bookmarks&numpg=10&id=666>
- Firefox Bookmark Share
<https://addons.mozilla.org/extensions/moreinfo.php?application=firefox&category=Bookmarks&numpg=10&id=617>

The Synchronizer looks the best candidate, b/c it uses WebDAV. Setting up a
central server would be easy.
(Reporter)

Comment 2

12 years ago
Hi!

Bookmark Synchronizer was exactly what i had in my mind and it works just
splendid on my ftp and http servers. It supports http, https and ftp. All i need
now is to see if the developer is interested in saving the same info in plain
html an option so i can access the same info from any browser without a plugin. 

Thank you very much! 

A happy Firefox User:

Daniel Hedblom

Comment 3

12 years ago
bug 273983 -> bug 260301

*** This bug has been marked as a duplicate of 260301 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.