text with z-index:auto goes over DIV with z-index:100

RESOLVED FIXED

Status

()

Core
Layout
--
major
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: Vit Timchishin, Unassigned)

Tracking

({testcase})

1.0 Branch
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

2.27 KB, text/html
Details
412 bytes, application/xml
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7.10) Gecko/20050720 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7.10) Gecko/20050720 Firefox/1.0.6

The page in attachments has blue div with z-index:100. But the violet contents
can be seen and selected over it. Note that only text is displayed, no backgroup
- background is correct.
Note that text size change removes problem until redraw.
P.S. Don't look at text itself - it is DOM Instpector "Copy XML" result from
Russian. The page was autogenerated with JS so I can't give you more isolated
variant.


Reproducible: Always

Steps to Reproduce:
1. Load the page
2. Look at two lined headers in violet
3. If they are OK, try enlarging textg size, reloading page and looking at "y"
letters

Actual Results:  
Parts of text from violet are drawn over blue and can even be selected

Expected Results:  
They should be under blue
(Reporter)

Comment 1

13 years ago
Created attachment 192357 [details]
testcase

Updated

13 years ago
Component: General → Layout
Keywords: testcase
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → 1.0 Branch

Comment 2

13 years ago
Vit, 
would it be possible for you to upload a *_reduced_* testcase showing the problem. As it is right now, the provided testcase (attachment 192357 [details]) is clearly unworkable and clearly not good.
The testcase (attachment 192357 [details]) contains 423 CSS declarations, 111 CSS rules, 958 lines of code, 18 nested tables with several of them deeply nested, 21 CSS parsing errors, dozens of CSS warnings, 939 markup validation errors.

What is a Simplified Test Case, and How Do I Make One?
http://www.mozilla.org/newlayout/bugathon.html#testcase
(Reporter)

Comment 3

13 years ago
Created attachment 203371 [details]
new testcase

It seems that overflow:hidden does the bug
Attachment #192357 - Attachment is obsolete: true

Comment 4

13 years ago
Created attachment 203386 [details]
another testcase

I hope this testcase is a bit easier to read. The same effect is also visible if 'overflow: hidden' is replaced with 'overflow: auto'.
(Reporter)

Comment 5

13 years ago
As for me, in this testcase it does not overflow one div over another, so everything is visible and if this is bug, this is another bug :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Tested against 'another testcase'

Testcase doesn't work with
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060124 Firefox/1.6a1 ID:2006012405
('Top Line 1' is visible in the grey box)

Testcase does work with
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1 ID:2006012613
('Top Line 1' not visible in the grey box)

--> RESOLVED FIXED (by bug 317375)
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

12 years ago
"New testcase" still showes problem at Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20061208 Firefox/2.0.0.1
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This looks like it was fixed on trunk. Vit, you're testing with a branch build. Please try a trunk build.
(Reporter)

Comment 9

12 years ago
Yep, sorry for disturbance. 
One question: This bug affects my commercial application. 
How can I determine which Firefox release will it get into?
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → FIXED
It is in for gecko 1.9 which will be included in firefox 3.
You need to log in before you can comment on or make changes to this bug.