Never Clear Passwords Option

RESOLVED INVALID

Status

()

Firefox
Preferences
--
enhancement
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Matthew, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050721 Firefox/1.0.6 (Ubuntu package 1.0.6)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050721 Firefox/1.0.6 (Ubuntu package 1.0.6)

What I would like to see is an option in 'Privacy > Saved Passwords' to 'Never
Clear Passwords'.

I like how in a single browser session I visit a site that prompts me for my
master password, and then FireFox remembers that 'Master Password' for future
sites in the same session. However at the end of that session if I am to open
Preferences > Privacy and click that wonderful 'Clear All' button ... Poof! all
my saved passwords are gone. :[

This 'Never Clear Passwords' idea of mine would make it so that the 'Clear All'
button does not even attempt to remove passwords stored in the password manager.

Also, I might add that I hope this is not a dup. bug ... In my search attempts
nothing appeared to fit exactly what I was looking for. And I'm glad it's not my
job to read all of these bugs / suggestions. (Humor intended) :P

Reproducible: Always

Steps to Reproduce:
1. Go to any site of your liking that prompts you for your master password, and
then auto fills the user id / password fields accordingly.
2. Open Preferences > Privacy
3. Click 'Clear All' and any passwords stored in the password manager are now
gone. :[

Comment 1

13 years ago
The "Clear All" button is gone on the trunk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.