Closed Bug 304372 Opened 19 years ago Closed 19 years ago

Doesn't support single-file web documents/archives

Categories

(Firefox :: File Handling, defect)

x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 40873

People

(Reporter: kristoferkrus, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; sv-SE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; sv-SE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Firefox doesn't support mht files. Well, this is not a bug, but it is one thing
that makes Firefox not as good as it could be. When I want to open an old mht
file, I have to use Internet Explorer, cause Firefox can not handle this file
format (even if mht-files commonly is accosiated with Internet Explorer, mht is
a pretty smart file format).
 And if I find a page I want to save in a single file, I can't do that in
Firefox, so I have to switch to Inernet Explorer. Hence, I rather use Internet
Explorer. This is quite a  problem.
 Firefox should in some way support single-file-archives, eigther mht document
or some own file format. The thing is that I have A LOT of old mht documents,
and I would appreciate if I didn't have to open them in another web browser
(IE), or have to save my new files in another file format.

Reproducible: Always

Steps to Reproduce:
1. I surf on the internet for a while.
2. Sudenly, I find an interesting article that I want to save.
3. I click on "File", "Save page as..." and try to find a propriate file format.

Actual Results:  
I can't find a propriate file format. This occurs every time i try to save a web
page in a single file.

Expected Results:  
Firefox should have displayed "Web Archive, single file" after the "Save as
type:" lable.

If this function is added to Firefox I would probably use Firefox as my standard
web browser.
Please search for duplicates before filling.

*** This bug has been marked as a duplicate of 40873 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.