If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

launching a second Firefox instance results in the profile selection window instead of opening the page in the existing Firefox instance

RESOLVED DUPLICATE of bug 268869

Status

()

Toolkit
Startup and Profile System
--
major
RESOLVED DUPLICATE of bug 268869
12 years ago
9 years ago

People

(Reporter: André Wyrwa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050810 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050810 Firefox/1.0.6

When a user already has an instance of Firefox open and he wishes to create
another Firefox windows from outside firefox (i.e. open a page by clicking a
link in evolution) Firefox won't be able to connect to the already open instance
and hence nothing will happen.

Reproducible: Always

Steps to Reproduce:
1. Launch Firefox
2. Open Terminal
3. type firefox http://www.google.de and enter
Actual Results:  
The profile selection box opens.

Expected Results:  
Open another firefox window or a tab in the current one to display the requested
page.


I figured that the problem is a missing line in the <prefix>/bin/firefox script
and this problem exists since 0.10.0 . I already filed it once as bug number
268869, but the bug was closed as resolved. The comment there doesn't make much
sense, since the fact that xremote isn't anymore is not related to anything the
patch does (in fact add just one line to find run-mozilla.sh).

This is the 7th Firefox version with this bug, please fix it.
(Reporter)

Comment 1

12 years ago
added dependency to 268869
Depends on: 268869
(Reporter)

Comment 2

12 years ago
changed component
Component: OS Integration → Startup and Profile System
This is fixed, if you download a current trunk nightly build you will see that
it is fixed.

Please don't file duplicate bugs.

*** This bug has been marked as a duplicate of 268869 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
No longer depends on: 268869
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

12 years ago
Ok, sorry, thought it was supposed to be solved in 1.0.6 already, since i had
the impression that the bug was closed before the release.

Comment 5

12 years ago
Created attachment 209848 [details] [diff] [review]
Fix missing line to set $run_moz after fallback to compile-time libdir

I stumbled upon this bug using Firefox 1.0.7 on solaris (installed in a custom directory) and pinpointed it down to a missing line in the firefox start script. From reading the related bug reports, I'm not entirely sure, if this bug is already fixed or not. I find the relevant line in
  mozilla/xpfe/bootstrap/mozilla.in
but it is missing from
  mozilla/browser/app/mozilla.in
both files from current CVS. My attached patch fixes the latter file.
Please clarify if this is an already fixed bug or not.
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.