Closed Bug 304386 Opened 19 years ago Closed 19 years ago

Double separators between Copy Image and Bookmark This Page (missing an item?) on context menu of broken image.

Categories

(SeaMonkey :: UI Design, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: stephend, Assigned: neil)

Details

(Keywords: fixed1.8, regression)

Attachments

(2 files)

Build ID: 2005-08-11-06, Windows XP SeaMonkey trunk.

Summary: Double separators between Copy Image and Bookmark This Page (missing an
item?) on context menu of broken image.

Steps to Reproduce:

1. Load the attached testcase.
2. Context-click the broken image.
3. Examine the resulting menu.

Actual Results:

View Image
Block Images from this Server (BTW, let's change casing to This to match
Bookmark This Page)
Copy Image
___________________
___________________
Bookmark This Page

Expected Results:

Not really sure, since this is a broken image (obviously, we shouldn't display
the Save Image As, Send Image and Set As Wallpaper of working images).
Flags: blocking-seamonkey1.0a?
Keywords: regression
Flags: blocking-seamonkey1.0a?
Reproducible with SeaMonkey/20050807 but Save Image As..., Send Image... and Set
As Wallpaper are visible with Mozilla 1.8b1.
Attached patch Proposed patchSplinter Review
Assignee: jag → neil.parkwaycc.co.uk
Status: NEW → ASSIGNED
Attachment #192541 - Flags: superreview?(dveditz)
Attachment #192541 - Flags: review?(bugzilla)
Attachment #192541 - Flags: review?(bugzilla) → review+
Attachment #192541 - Flags: superreview?(dveditz) → superreview?(jag)
Attachment #192541 - Flags: superreview?(jag) → superreview+
Fix checked in to the trunk.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Comment on attachment 192541 [details] [diff] [review]
Proposed patch

Regression fix.
Attachment #192541 - Flags: approval1.8b4?
Attachment #192541 - Flags: approval1.8b4? → approval1.8b4+
Verified FIXED using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1)
Gecko/20050817 Mozilla/1.0

I now see:

View Image
Block Images From this Server
Copy Image
_____________________________
Bookmark This Page
Status: RESOLVED → VERIFIED
Keywords: fixed1.8
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: