Change the b.m.o My Bugs template so that for reporters only, UNCONFIRMED bugs are shown as well

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
General
RESOLVED FIXED
13 years ago
4 years ago

People

(Reporter: Wurblzap, Assigned: justdave)

Tracking

Details

(Reporter)

Description

13 years ago
This is not intended to be just another dupe of bug 28357 ;)

This bug here wants to solve the issue at hand that reporters miss their
UNCONFIRMED bugs when looking at My Bugs while assignees don't want to see them.
This can be done with an advanced query. This template makes My Bugs look at all
open bugs, and lets UNCONFIRMED ones pass only if you're the reporter:

bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&emailassigned_to1=1&emailreporter1=1&emailtype1=exact&email1=%userid%&field0-0-0=bug_status&type0-0-0=notequals&value0-0-0=UNCONFIRMED&field0-0-1=reporter&type0-0-1=equals&value0-0-1=%userid%
runs fairly quick, too. :)

Done.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

13 years ago
Argh. All occurrences of "&" should be replaced by "&", of course.

Sorry for neglecting to specify them so in the first place.
in the params?  Isn't that the job of the template when it puts it on the web page?
(Reporter)

Comment 4

13 years ago
Maybe, but it doesn't :)

Current defparams.pl works around, too
(http://lxr.mozilla.org/mozilla/source/webtools/bugzilla/defparams.pl#694).
(Reporter)

Comment 5

12 years ago
Reopening because of comment 2 (sorry)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #5)
> Reopening because of comment 2 (sorry)

Fixed. Bug 313690 opened for the escaping issue (Bugzilla should really do that for you).
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → FIXED
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.