Left-clicked downloadable files do not have their links marked as visited until a page reload

VERIFIED FIXED

Status

VERIFIED FIXED
13 years ago
3 months ago

People

(Reporter: kakadu+bugzilla, Assigned: roc)

Tracking

({fixed1.8, regression})

Trunk
x86
All
fixed1.8, regression
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050811 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050811 Firefox/1.0+

Bug 78510's fix does not take into account any left-clicked links which cause
the browser to begin a file download. Left-clicking these links does not mark
them as visited until after the page is reloaded.

Reproducible: Always

Steps to Reproduce:
1. Go to the Web site in the URL field.
2. Left-click a file that will cause a download to start.
3. Start the download.
4. Return to the Web site and find the link that was clicked.
Actual Results:  
The link is still unvisited (a:link) instead of visited (a:visited).

Expected Results:  
The link should have changed to a:visited after the download dialog had appeared
and/or the download had been started in the DM.
CCing roc, as he wrote the original fix for this.

Adding dependency on 78510 (if unneeded, please remove).
Depends on: 78510
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

13 years ago
not only a linux problem

can confirm here with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
Gecko/20050812 Firefox/1.0+ ID:2005081201

same behaviour, not marked visited until reload

Updated

13 years ago
OS: Linux → All
downloads call the add-to-history code themselves, in
nsExternalHelperAppService.cpp, so they don't reach the notifyObservers code in
docshell
Blocks: 78510
No longer depends on: 78510
Created attachment 192898 [details] [diff] [review]
fix

Simple fix
Assignee: nobody → roc
Status: NEW → ASSIGNED
Attachment #192898 - Flags: superreview?(dbaron)
Attachment #192898 - Flags: review?(dbaron)
This is a regression since I took out the Firefox hack that used to make this
"kinda" work.
Keywords: regression
Actually, wouldn't it be better if the AddURI / AddPage implementation did this?
 After all, the current way leaves inconsistencies on reload, since AddURI
refuses to add certain schemes to history.
Attachment #192898 - Flags: superreview?(dbaron)
Attachment #192898 - Flags: superreview-
Attachment #192898 - Flags: review?(dbaron)
Attachment #192898 - Flags: review-
Then we'd have to add it to all history implementations (including those outside
our tree).
I don't think this will cause inconsistencies because style reresolution will
just find that the link is still not visited and do the right thing.
Comment on attachment 192898 [details] [diff] [review]
fix

resubmitting patch
Attachment #192898 - Flags: superreview?(dbaron)
Attachment #192898 - Flags: superreview-
Attachment #192898 - Flags: review?(dbaron)
Attachment #192898 - Flags: review-
Attachment #192898 - Flags: superreview?(dbaron)
Attachment #192898 - Flags: superreview+
Attachment #192898 - Flags: review?(dbaron)
Attachment #192898 - Flags: review+
Comment on attachment 192898 [details] [diff] [review]
fix

fixes a regression from bug 78510
Attachment #192898 - Flags: approval1.8b4?

Updated

13 years ago
Flags: blocking1.8b4+

Updated

13 years ago
Attachment #192898 - Flags: approval1.8b4? → approval1.8b4+
checked in on branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050827 Firefox/1.0+
ID:2005082705

Verified - but not totally fixed. Right-clicking a link and selecting Save Link
As  does not trigger the fix in this bug, and additionally does not allow such a
link to be marked visited at all, even after a page reload.

Should a new bug be filed on this issue?
Status: RESOLVED → VERIFIED
(In reply to comment #13)
> Should a new bug be filed on this issue?

That never marked the link as visited. There already is a bug on that.

Updated

3 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.