Moving a tab can cause wrong content to be loaded

VERIFIED INVALID

Status

()

VERIFIED INVALID
13 years ago
13 years ago

People

(Reporter: elfguy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050812 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050812 Firefox/1.0+

When moving a tab around, closing a new tab then selecting the previous location
reloads the old tab under the wrong title.

Reproducible: Always

Steps to Reproduce:
1- Open 4 tabs
2- Drag tab #4 to position #2
3- Select tab #1
4- Open a new empty tab
5- Close the empty tab
6- Click on tab #4

Actual Results:  
You will be in tab #4 but with the content of tab #2.

Comment 1

13 years ago
Can you reproduce this in safe mode? http://kb.mozillazine.org/Safe_mode
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050812
Firefox/1.0+ ID:2005081203 + new profile.
(Reporter)

Comment 3

13 years ago
Cause found: FLST extension needs to be installed with the option to "focus last
selected tab" for this bug to occur.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 4

13 years ago
I noticed this off and on over the past two weeks. If you fiddle with flst
(uninstall/reinstall, dump prefs, etc), does it get better? I wasn't able to
reproduce this with a new profile. Strange... but it'll prolly come back later.

When tab-flipping is enabled (default), trunk really goes bonkers.. Can't change
tabs or anything. I think it just needs a refresher for 1.1, but haven't asked
the author about it.

Comment 5

13 years ago
The following is a minimalistic patch for flst which corrects this problem.

--- content/flst/flst.js.orig   2005-03-15 15:41:29.000000000 -0600
+++ content/flst/flst.js        2005-09-06 18:10:34.000000000 -0500
@@ -108,9 +108,6 @@
           // make sure first tab is in tabHistory
           if (flst.tabHistory.length == 0)
             flst.tabHistory.push(nt);
-          event.preventDefault();
-          flst.tabBox.addEventListener('select', flst.correctFocus, true);
-          return;
         }
       }
     }

Daniel said it was used to work around an odd bug which caused ui problems in
older versions of firefox and that it has since been removed in his development
version.

Comment 6

13 years ago
Issues with FLST should be addressed with its author, and not on Bugzilla. We
can't do anything about it, and commenting here is just a waste of your time.

Comment 7

13 years ago
I'm commenting for the sake of the reporter, those cc'd, and others who may end
up at this bug.

Comment 8

13 years ago
*** Bug 307386 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
*** Bug 307611 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED

Comment 10

13 years ago
*** Bug 308041 has been marked as a duplicate of this bug. ***

Comment 11

13 years ago
*** Bug 305788 has been marked as a duplicate of this bug. ***
*** Bug 310667 has been marked as a duplicate of this bug. ***

Comment 13

13 years ago
Could not reproduce the problem in safe mode.

But when the "Tabbrowser Preferences" Extension (v 1.2.8.5) is enabled, this
problem comes up.

Comment 14

13 years ago
*** Bug 315529 has been marked as a duplicate of this bug. ***

Comment 15

13 years ago
*** Bug 298226 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.