Closed Bug 304466 Opened 16 years ago Closed 16 years ago

SSL Icon for IMAP Accounts no longer shows up

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
Thunderbird1.1

People

(Reporter: mscott, Assigned: mscott)

References

Details

(Keywords: fixed1.8)

Attachments

(1 file)

Using 08/12 nightly. 

Turn on SSL for an imap account. Note that the SSL icon in the folder pane no
longer shows up like it used to for that account.

The CSS in the folder pane is looking for the isSecure property on the server.

It looks like we no longer set isSecure for imap, but instead set the socketType.
To fix this properly, I suspect we should do the following:

1) Make nsMsgFolderDatasource listen for changes to the server's socket type
connection (to handle the case where we 'step up' to SSL).

2) Modify nsIMsgIncomingServer::IsSecure to reflect the real state of the
connection instead of looking at the obsolete connection type

3) When the connection changes from non secure to secure, the folder data source
can rebroadcast the isSecure attribute change out to the style system.
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird1.1
Attached patch the fixSplinter Review
Instead of checking isSecure, look at the socket connection type and for SSL
and always TLS, it is safe to set the secure property on the server.

This restores us to 1.0.x behavior.
Attachment #192533 - Flags: superreview?(bienvenu)
Attachment #192533 - Flags: superreview?(bienvenu) → superreview+
Attachment #192533 - Flags: approval1.8b4?
fixed on the trunk
*** Bug 301114 has been marked as a duplicate of this bug. ***
Attachment #192533 - Flags: approval1.8b4? → approval1.8b4+
fixed branch and trunk
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Keywords: fixed1.8
Verified FIXED using:

SeaMonkey build 2005-08-19-06
Thunderbird build version 1.6a1 (20050819)

on Windows XP.

Trunk verification only at this point.
Status: RESOLVED → VERIFIED
Depends on: 316245
You need to log in before you can comment on or make changes to this bug.