remove app.extensions.version from firefox.js

RESOLVED FIXED in Firefox1.5

Status

defect
P1
normal
RESOLVED FIXED
14 years ago
6 months ago

People

(Reporter: chase, Assigned: benjamin)

Tracking

({fixed1.8})

Trunk
Firefox1.5
Dependency tree / graph
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

14 years ago
Remove app.extensions.version from firefox.js on Mozilla 1.8 branch.
Assignee

Updated

14 years ago
Flags: blocking1.8b4+
Whiteboard: ETA 8/15
Assignee

Comment 1

14 years ago
The problem with any version number bump is that we have extensions all over
the tree that care a lot. So what I have done is always pull the firefox/tbird
version.txt, and make the current version of these apps always available via a
makefile var. Then we can bump the app+extension version number with a single
change to version.txt without worrying about the rest of the tree.
Attachment #192750 - Flags: review?(chase)
Assignee

Updated

14 years ago
Blocks: 304478
Assignee

Comment 2

14 years ago
BTW, this patch is for trunk and branch.
Priority: -- → P1
Whiteboard: ETA 8/15 → has patch, needs review (chase)
Target Milestone: --- → Firefox1.5
Reporter

Updated

14 years ago
Attachment #192750 - Flags: review?(chase) → review+
Assignee

Comment 3

14 years ago
Comment on attachment 192750 [details] [diff] [review]
Pull extension min/maxversion numbers from the proper version.txt instead of hardcoding

This is cycling on trunk now: low-risk if it builds ;-)
Attachment #192750 - Flags: approval1.8b4?

Updated

14 years ago
Attachment #192750 - Flags: approval1.8b4? → approval1.8b4+
Assignee

Comment 4

14 years ago
Fixed on 1.8 branch also.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
I just downloaded Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
Gecko/20050817 Firefox/1.0+ ID:2005081721 and the install.rdf's have
@FIREFOX_VERSION@ and @THUNDERBIRD_VERSION@ for minVersion and maxVersion. On
the trunk I see the appropriate minVersion and maxVersion for Firefox (e.g.
1.6a1) but the minVersion and maxVersion for Thunderbird is empty.

Side note: @FIREFOX_VERSION@ is not considered incompatible but that is a
different issue.
Assignee

Comment 6

14 years ago
(In reply to comment #5)
> I just downloaded Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
> Gecko/20050817 Firefox/1.0+ ID:2005081721 and the install.rdf's have
> @FIREFOX_VERSION@ and @THUNDERBIRD_VERSION@ for minVersion and maxVersion. On

This is because the 1.8 branch doesn't auto-commit configure :-(... I have
manually committed configure and this should be fixed.

> Side note: @FIREFOX_VERSION@ is not considered incompatible but that is a
> different issue.

It's not!? Do you know why? It should be interpreted as "0@FIREFOX_VERSION@"
which should be less than 1.4...
(In reply to comment #6)
> It's not!? Do you know why? It should be interpreted as "0@FIREFOX_VERSION@"
> which should be less than 1.4...
I haven't had time to debug it yet due to having a hell of a week (lost a hard
drive on my dev system and my public web server within 2 days and other issues I
won't bore you with). I only had time to barely look into it and I am very sure
that @FIREFOX_VERSION@ was in both the install.rdf and extensions.rdf for these
items and they were enabled which infers compatibility. I should have time to
look into it more in the next day or two as long as lightning doesn't strike me.
I forgot to reply that the reason they were not marked as incompatible was due
to one of the regressions that happened at the same time and is fixed.
This patch doesn't do the right thing for depend builds (see bug 330528 comment 4).

Updated

13 years ago
Hardware: PC → All
Summary: remove app.extensions.version from firefox.js on Mozilla 1.8 branch → remove app.extensions.version from firefox.js
Whiteboard: has patch, needs review (chase)
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.