frame/Iframe titles are not reported properly by Window-Eyes. This works ok with IE

RESOLVED FIXED

Status

()

Firefox
Disability Access
P2
normal
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Dan Kinnunen, Assigned: Aaron Leventhal)

Tracking

({access, fixed1.8})

Trunk
x86
Windows XP
access, fixed1.8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: IBMQA, URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Iframe titles are not reported properly by Window-Eyes.  This works ok with IE.
TC: Web Content: Frames


Steps to recreate:

Start Window-Eyes and Firefox.
1. Open www.monster.com
2. Press Insert+Tab to display Page Navigation dialog
3. Select Frames radio button in Information Selection area to display frames.
Expected result: Should see multiple frames with title “Advertisement”.
Actual result: See multiple frames with title “untitled”
(Reporter)

Updated

12 years ago
Priority: -- → P2
Whiteboard: IBMQA
(Assignee)

Comment 1

12 years ago
*** Bug 304489 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

12 years ago
Summary: Iframe titles are not reported properly by Window-Eyes. This works ok with IE → frame/Iframe titles are not reported properly by Window-Eyes. This works ok with IE
(Assignee)

Updated

12 years ago
Assignee: nobody → aaronleventhal
(Assignee)

Comment 2

12 years ago
Created attachment 192749 [details] [diff] [review]
Either out or inner doc could have a name. Let each prefer it's own or use the other's as a fallback. The nsAccessible::GetName() method supports DHTML a11y names and the title attribute.

Also fixes issue where frame/iframe accessibles weren't allow to have siblings
Attachment #192749 - Flags: superreview?(dmose)
Attachment #192749 - Flags: review?(parente)

Comment 3

12 years ago
Comment on attachment 192749 [details] [diff] [review]
Either out or inner doc could have a name. Let each prefer it's own or use the other's as a fallback. The nsAccessible::GetName() method supports DHTML a11y names and the title attribute.

sr=dmose
Attachment #192749 - Flags: superreview?(dmose) → superreview+
(Assignee)

Updated

12 years ago
Attachment #192749 - Flags: review?(parente) → review?(timeless)

Updated

12 years ago
Attachment #192749 - Flags: review?(timeless) → review+
(Assignee)

Updated

12 years ago
Attachment #192749 - Flags: approval1.8b4?

Updated

12 years ago
Attachment #192749 - Flags: approval1.8b4? → approval1.8b4+
(Assignee)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Any reason this was checked in while the tree was closed?
You need to log in before you can comment on or make changes to this bug.