Ignore matches fails for CASEMAPPINGS outside of A-Z

RESOLVED FIXED

Status

--
trivial
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Gijs, Assigned: bugzilla-mozilla-20000923)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-0.9.69], URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
... which means it buggers because the ignores are lowercased using that method,
and /i doesn't cut it when a server uses rfc1459 charsets. Patch by Silver
coming up, as I understand it.
(Assignee)

Updated

13 years ago
Summary: Ignore matches using the /i regexp option instead of lowercasing using e.server.toLowerCase → Ignore matches fails for CASEMAPPINGS outside of A-Z
(Assignee)

Updated

13 years ago
Blocks: 299458
Whiteboard: [cz-0.9.68.6]
(Assignee)

Comment 1

13 years ago
Created attachment 192549 [details] [diff] [review]
Lower-cases nickname properly before comparing
Attachment #192549 - Flags: review?(samuel)
(Reporter)

Comment 2

13 years ago
Comment on attachment 192549 [details] [diff] [review]
Lower-cases nickname properly before comparing

Discussed on IRC, seems fine to me :-).
Attachment #192549 - Flags: review+

Updated

13 years ago
Attachment #192549 - Flags: review?(samuel) → review+

Comment 3

13 years ago
shouldnt this actually be a bug in the regexp parsing engine?
(Assignee)

Comment 4

13 years ago
Um, why? The problem is ^, [, ] and \ are not being matched to ~, {, } and |.
(Assignee)

Comment 5

13 years ago
Checked in --> FIXED.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Updated

13 years ago
Blocks: 318336
(Assignee)

Updated

13 years ago
Whiteboard: [cz-0.9.68.6] → [cz-0.9.69]
You need to log in before you can comment on or make changes to this bug.