arrow keys should not accept auto completion suggestion

RESOLVED INVALID

Status

RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: hrosik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: WONTFIX)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.11) Gecko/20050731 MultiZilla/1.7.9.0a
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.11) Gecko/20050731 MultiZilla/1.7.9.0a

When composing mail message, horizontal movement keys work as confirmation in
the recipient address field. They should not - left/right movement (arrows,
home/end...) is intended for making corrections in the input. For selecting one
of the suggestions we have <Enter>.

The behaviour should be the same as for the URL bar completion, i.e. <Enter>
selects, horizontal movement cancels suggestions list.

Reproducible: Always

Steps to Reproduce:

Comment 1

13 years ago
Umm, how is a person then supposed to be able to edit the suggested completion?  If you want to get back what you typed, hit delete or backspace first.
Whiteboard: WONTFIX
(Reporter)

Comment 2

13 years ago
OK, I found out that pressing <Esc> gets me back to what I entered, so the bug was irrelevant.

However, just hitting <BS> or <Del> won't get you anywhere, as it erases a character from already completed input.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.