Showing and hiding DIVs alters bellow elements position

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: filipe.martins, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-PT; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-PT; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Well, I have an example here in which the content that is bellow two DIVs goes
down when I hide the first one and show the other!
I think this is strange. Using table cells instead of DIVs all goes well!
IE 6 does the right thing: It doesn't touch the contents bellow the DIVs!

Se see the test in http://fmart.atspace.org/ff/ShowAndHide-div.html and the one
using a table in http://fmart.atspace.org/ff/ShowAndHide-tab.html (this works fine)


Reproducible: Always

Steps to Reproduce:
1. Load the url I gave
2. Press << 1 >>
3. Than << 2 >>

Actual Results:  
The content bellow the DIVs I show and hide stepped down

Expected Results:  
The content bellow shouldn't move.
Works for me. Please test on a more recent nightly build of firefox.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050814
Firefox/1.0+ ID:2005081400

->WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.