CSS inline-block display attribute rendered incorrectly as block elements

RESOLVED DUPLICATE of bug 9458

Status

()

defect
RESOLVED DUPLICATE of bug 9458
14 years ago
14 years ago

People

(Reporter: jab_creations, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050813 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050813 Firefox/1.0+

Items set to inline-block are rendered as block elements.
inline-block treats an item as a block but does not break lines before and after
the object.
h1.item1 {display: inline-block}
h2.item1 {display: inline-block}

Opera 8.02 correctly renders the URL in question.

This leads to the inability to use...
h1:first-letter {...}

Reproducible: Always

Steps to Reproduce:




http://www.w3.org/TR/2004/CR-CSS21-20040225/visuren.html#display-prop
inline-block isn't implemented, see bug 9458.
Now, there is a -moz-inline-block, but that's considered not good enough to
become inline-block.

*** This bug has been marked as a duplicate of 9458 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.