Open Bug 304686 Opened 15 years ago Updated 13 years ago

[quirks] <IMG height=100%> inside table renders differently than other UAs

Categories

(Core :: Layout: Tables, defect)

defect
Not set
normal

Tracking

()

REOPENED

People

(Reporter: cfbl, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: compat, testcase, Whiteboard: DUPEME)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nb-NO; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nb-NO; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

http://www.earthwalkers.no/ on browswr gets up only some small fragments of the
page, but is ok in IE.

Reproducible: Always
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050815
Firefox/1.0+ ID:2005081501

It looks fine, as long as I don't reload the page before clearing the cache.
Disability access relates to how people with sensory or motor impairments use
Firefox.
Component: Disability Access → General
QA Contact: disability.access → general
Incremental reflow issue... probably a dupe.
Component: General → Layout
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → layout
Hardware: PC → All
Version: unspecified → Trunk
Summary: only fragments of page coming up → {inc}only fragments of page coming up
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050815
Firefox/1.0+
The layout looked fine on first load.  When I hit reload, the layout went very bad.
Attached file Testcase #1 (obsolete) —
Component: Layout → Layout: Tables
Keywords: testcase
QA Contact: layout → layout.tables
I can't tell what correct rendering for that testcase is...
Keywords: qawanted
Attached file Testcase #2
The bug only occurs in quirks mode.
Attachment #192803 - Attachment is obsolete: true
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
Summary: {inc}only fragments of page coming up → [quirks]{inc}only fragments of page coming up
Whiteboard: [reflow-refactor]
Weirdness observed with:
-  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120606 Minefield/3.0a (pre-reflow branch)
(SHIFT-Reload, Reload, SHIFT-Reload changes page layout)

No weirdness observed with:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120804 Minefield/3.0a1 (post-reflow branch)
(SHIFT-Reload, Reload, SHIFT-Reload does not change page layout)

-->RESOLVED FIXED
Status: NEW → RESOLVED
Closed: 14 years ago
Depends on: reflow-refactor
Resolution: --- → FIXED
Yeah, the {inc} problem seems to be fixed. I wonder if the new rendering
is correct though. The URL works fine in IE7, Opera9 and Safari 2.04 (Webkit
nightly). Testcase #2 also renders differently in those UAs - none of them
makes the image as tall as we do. Given that this is Quirks mode,
I think we need to analyze this further...

-> REOPEN
Status: RESOLVED → REOPENED
Keywords: compat
Resolution: FIXED → ---
Summary: [quirks]{inc}only fragments of page coming up → [quirks] <IMG height=100%> inside table renders differently than other UAs
Whiteboard: [reflow-refactor]
Blocks: 220007
See also bug 373612, which seems similar but isn't limited to quirks mode.
This has come up before.  When exactly do things do quirks containing block heights with table cells?  No one's come up with a straight answer.
Whiteboard: DUPEME
Related to bug 385823?
You need to log in before you can comment on or make changes to this bug.