Last Comment Bug 304704 - Unable to subscribe to feed URLs passed from browsers (Mac)
: Unable to subscribe to feed URLs passed from browsers (Mac)
Status: RESOLVED FIXED
: fixed1.8
Product: MailNews Core
Classification: Components
Component: Feed Reader (show other bugs)
: Trunk
: PowerPC Mac OS X
: P1 major with 4 votes (vote)
: Thunderbird 3
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 380520 400006 416401 434422 471007 495658 514385 530487 534732 540789 (view as bug list)
Depends on: 380163
Blocks: 348450
  Show dependency treegraph
 
Reported: 2005-08-15 06:41 PDT by Mano (::mano, needinfo? for any questions; not reading general bugmail)
Modified: 2014-12-21 00:12 PST (History)
24 users (show)
mkmelin+mozilla: blocking‑thunderbird3-
mkmelin+mozilla: wanted‑thunderbird3+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
[patch checked in] handle feed:// urls (1.20 KB, patch)
2005-08-23 16:59 PDT, Scott MacGregor
mozilla: superreview+
Details | Diff | Splinter Review
[checked into the branch] branch-only patch (3.40 KB, patch)
2005-09-02 05:32 PDT, Mano (::mano, needinfo? for any questions; not reading general bugmail)
mscott: review+
mscott: superreview+
Details | Diff | Splinter Review

Description Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-08-15 06:41:36 PDT
For some reason, I tought this stuff is already done... If I  click on feed://
URIs in Firefox, thunderbird opens open a new message window.

I am going to debug this tomorrow, if it turns out this isn't fixable for 1.8, I
will disable the feed handling in the mac shell service...
Comment 1 Magnus Melin 2005-08-21 08:35:44 PDT
Just a note: From bug 282048 comment 5: "I don't yet handle feed://<some url>,
just feed:<some url>." 
Comment 2 Scott MacGregor 2005-08-22 12:50:41 PDT
My reg expression foo is not strong enough. I'm sure someone else can come up
with the right foo for:

aUrl = aUrl.replace(^feed:/i, '');

feed: needs to really be, feed: followed by 0 or two forward slashes (//)

that will allow us to strip out both:
feed://http://myfeed.xml
and
feed:http://myfeed.xml

I keep having problems when I try to put two forward slashes in my reg
expression. \/\/ doesn't seem to work either.
Comment 3 Scott MacGregor 2005-08-23 16:59:42 PDT
Created attachment 193632 [details] [diff] [review]
[patch checked in] handle feed:// urls

My reg expression foo is not strong enough to figure out a way to do this in
one line so I'm doing it in two.

if the string beings with feed:, strip feed: from the url 
and then if we have two forward slashes left, strip those off too. 

this means we now work with feed: and feed:// when receiving feed urls from the
desktop.
Comment 4 David :Bienvenu 2005-08-23 17:01:04 PDT
Comment on attachment 193632 [details] [diff] [review]
[patch checked in] handle feed:// urls

+    // feeed://http://somesite/feed.xml

s/feeed/feed
Comment 5 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-08-24 00:42:37 PDT
Scott, have you tested this on mac (I didn't have a chance, yet). I am pretty
sure we have _another_ issue there.
Comment 6 Scott MacGregor 2005-08-24 11:28:06 PDT
whoops, your right. the comment about not handling feed:// threw me off since I
know we didn't have that support yet.

re-opening, assigning back to you. On the mac I still see a compose window come
up when given either a feed: or a feed:// uri.
Comment 7 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-08-29 17:10:23 PDT
OK, the mac command line handling code is a crap and will only get fixed in the
1.9 timeframe; we'll have to only expose the mail part of the default client UI.
Comment 8 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-09-02 05:32:20 PDT
Created attachment 194652 [details] [diff] [review]
[checked into the branch] branch-only patch

This removes the news and feeds part of this UI for 1.5. I'll rework the mac
commandline service on the trunk so this isn't necessary there.
Comment 9 Scott MacGregor 2005-09-02 14:47:45 PDT
i left this in on the trunk as we work on a real solution. Leaving open but
moving off the 1.1 radar. 
Comment 10 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-09-02 14:55:47 PDT
Scott, in the future, I prefer to keep cvs blame usable, thanks.
Comment 11 Scott MacGregor 2005-09-02 14:56:31 PDT
(In reply to comment #10)
> Scott, in the future, I prefer to keep cvs blame usable, thanks.

?
Comment 12 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-09-02 14:57:58 PDT
I could check this in myself and keep the log a bit more usable, that's all. :)
Comment 13 Soyapi Mumba 2006-02-20 04:50:50 PST
Just want to add that I've faced a similar problem in Windows and Linux too!

When using Firefox with Livelines extension to pass the feed url to Thunderbird, it does not accept feed://domain.com/abc.xml urls (domain/abc.xml is not a valid RSS feed). It only accepts feed:http://domain.com/abc.xml or feed://http://domain.xml

It seems alot of RSS Readers use http as the default, except Thunderbird.

Using TB 1.5
Comment 14 Scott MacGregor 2006-03-04 13:03:42 PST
Soyapi, file a new bug and assign it to me and I'll take a look. Thanks!
Comment 15 Scott MacGregor 2007-01-30 18:33:24 PST
looks like this is slipping to 1.9 per comment 7
Comment 16 Christian Schmidt 2007-04-30 00:57:26 PDT
> My reg expression foo is not strong enough to figure out a way to do this in
> one line so I'm doing it in two.
Here is a one-line version:
aUrl = aUrl.replace(/^feed:(\/\/)?/,'');


The code doesn't seem right, though, at least not according to this spec (I'm not sure whether there is considered authoritative):
http://www.25hoursaday.com/draft-obasanjo-feed-URI-scheme-02.html

feed://http://somesite/feed.xml (as mentioned in the patch) doesn't look like a valid feed URL. The format is either feed:http://somesite/feed.xml or feed://somesite/feed.xml.
Comment 17 Phil Ringnalda (:philor) 2007-04-30 01:08:56 PDT
Yup. That, however, isn't this bug - "Mac-only, feed URLs open a compose window" - it's bug 329501, which will actually be fixed by bug 348450 (once I get over my mad about this bug, and just land something that only works on the two platforms I rarely use, and fails on the one I mostly use).
Comment 18 Phil Ringnalda (:philor) 2007-05-03 23:59:37 PDT
Okay, I know the *what* now, though I'm still unsure about the *how* (to avoid it):

If we are not running when a browser launches us with "feed://example.org/feed/", then we wind up with commandline arguments of "-url", "feed://example.org/feed/", "-foreground". Then http://ln-s.net/U7w fails to recognize "-url", and for backward-compat eats both it and the feed: URL. Easy enough to hack around, with an #ifdef XP_MACOSX handleFlagWithParam("url").

If we *are* running, though, we go clattering through toolkit's Mac commandline handling stuff until we fall out in http://ln-s.net/U82 where because of bug 234541 we get the feed: URL passed to messengercompose.xul, our OS X default for browser.chromeURL, which not surprisingly has no idea what to do with it.

So far, the closest thing to an idea for dealing with that I've come up with is to instead use hiddenWindow.xul for browser.chromeURL, and give it a window.arguments parser that will open a compose window for mailto:, or pass feed: to a 3-pane.
Comment 19 Phil Ringnalda (:philor) 2007-05-09 09:49:32 PDT
Filed bug 380163 on fixing toolkit to actually call command-line-handers for commandlines, since I failed to grasp that this Thunderbird bug was Mano's Toolkit bug for that.
Comment 20 Stuart Morgan 2007-05-12 15:18:12 PDT
*** Bug 380520 has been marked as a duplicate of this bug. ***
Comment 21 Stuart Morgan 2007-10-16 07:23:55 PDT
*** Bug 400006 has been marked as a duplicate of this bug. ***
Comment 22 Magnus Melin 2008-02-08 11:40:27 PST
*** Bug 416401 has been marked as a duplicate of this bug. ***
Comment 23 Phil Ringnalda (:philor) 2008-05-19 13:52:15 PDT
*** Bug 434422 has been marked as a duplicate of this bug. ***
Comment 24 Magnus Melin 2008-10-21 11:59:23 PDT
Don't think this is a blocker considering bug 348450 will improve things quite a bit, right?
Comment 25 Phil Ringnalda (:philor) 2008-10-21 12:29:47 PDT
Not really: it would be more accurate to say that there are two bugs:

Bug 348450 Can't subscribe to feeds passed from Firefox (Windows & Linux)
Bug 304704 Can't subscribe to feeds passed from Firefox (Mac)

(But I don't think marking it as a blocker will magically make someone able to figure out how to fix toolkit's commandline handling.)
Comment 26 Phil Ringnalda (:philor) 2008-12-23 19:42:15 PST
*** Bug 471007 has been marked as a duplicate of this bug. ***
Comment 27 Phil Ringnalda (:philor) 2009-05-30 23:22:45 PDT
*** Bug 495658 has been marked as a duplicate of this bug. ***
Comment 28 Phil Ringnalda (:philor) 2009-09-03 07:32:32 PDT
*** Bug 514385 has been marked as a duplicate of this bug. ***
Comment 29 Phil Ringnalda (:philor) 2009-11-23 07:24:30 PST
*** Bug 530487 has been marked as a duplicate of this bug. ***
Comment 30 Phil Ringnalda (:philor) 2009-12-14 14:14:38 PST
*** Bug 534732 has been marked as a duplicate of this bug. ***
Comment 31 Phil Ringnalda (:philor) 2010-01-19 22:43:42 PST
*** Bug 540789 has been marked as a duplicate of this bug. ***
Comment 32 Gregor Riepl 2010-02-21 18:27:28 PST
what's the status of this 4 years old bug?
is someone still working on it?

i tested with a current nightly trunk build (2010-02-21, new empty profile with just an RSS account created) and i get
Warning: unrecognized command line flag -url
on the console instead of the feed being subscribed in tb.

doesn't look like the fixed1.8 flag has any meaning if it's still not working in 1.9?
Comment 33 alta88 2012-03-09 16:20:12 PST
see bug 646031.  -url is not how to do it.
Comment 34 alta88 2012-09-26 11:41:11 PDT
if the procedure in bug 646031 comment 3 does not work on mac, reopen.
Comment 35 Mitar 2014-12-21 00:09:06 PST
This is the problem because Firefox (tested on 34.0 on Mac OS X) sends an `-url` parameter when subscribing to a feed. So if I navigate to the website with a RSS feed in Firefox, click Bookmarks -> Subscribe to this page and I choose Thunderbird to open it, Thunderbird gets focused, but nothing happens, and in the Console I see the error above. Thunderbird 31.3.0.
Comment 36 Mitar 2014-12-21 00:12:32 PST
So this is a problem because Firefox sends such parameters to the program. The procedure in bug 646031 comment 3 does not help, because the question is how to get or Firefox to send correct parameters, or how to get Thunderbird to accept the parameters Firefox sends.

Note You need to log in before you can comment on or make changes to this bug.