Duplicate filtered messages occur when multiple applications open checking IMAP

RESOLVED DUPLICATE of bug 193325

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 193325
13 years ago
12 years ago

People

(Reporter: Doug, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla Thunderbird 1.0.6

When a "move to folder" filter is used, multiple copies of the same message will
appear in the intended folder if more than one instance of Thunderbird is open
on seperate computers.
This happens when using an IMAP server, and messages stay on the server. The
filter get applyed once per open application, and duplicate messages show up.

Reproducible: Always

Steps to Reproduce:
1. Open thunderbird on computer A
2. Create filter to move message to folder
3. Open thunderbird on computer B
4. Create same filter
5. Check messages on A, and receive a message which gets filtered to a folder
6. Same as #3 for B

Actual Results:  
Message gets sent to folder after first instance checks mail and also when
second instance checks, leaving the folder with two instances of the same message.

Expected Results:  
Only one copy of the message should show up in the folder
(Reporter)

Updated

13 years ago
Version: unspecified → 1.0

Comment 1

13 years ago
Duplicate of/related to Core Bug 214297 -> Core bug 193325?

Comment 2

12 years ago
Agreed, dupe.

*** This bug has been marked as a duplicate of 193325 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.